Opened 8 days ago

Closed 6 days ago

#7536 closed defect (fixed)

ffplay - "not implemented"-warnings flood the terminal

Reported by: Djfe Owned by:
Priority: minor Component: avformat
Version: git-master Keywords: apng
Cc: Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: no

Description

Summary of the bug:
The apng files from this page (https://flif.info/animation.html) generate a (seemingly) endless output of

 In-stream tag=[0][0][0][0] (0x00000000) len=0 is not implemented. Update your FFmpeg version to the newest one from Git. If the problem still occurs, it means that your file has a feature which has not been implemented.
[apng @ 000001bc46816f80] If you want to help, upload a sample of this file to ftp://upload.ffmpeg.org/incoming/ and contact the ffmpeg-devel mailing list. (ffmpeg-devel@ffmpeg.org)

Or rather only the cut off apng files cause this (the ones in the bottom row on the page)

This only happens when I play them with ffplay. ffmpeg and ffprobe only output one warning (or error)

How to reproduce:

PS C:\Users\Felix\Downloads> ffplay .\spinfox_cut53.png
ffplay version N-91273-g67747c89ad Copyright (c) 2003-2018 the FFmpeg developers
  built with gcc 7.3.0 (GCC)
  configuration: --enable-gpl --enable-version3 --enable-sdl2 --enable-bzlib --enable-fontconfig --enable-gnutls --enable-iconv --enable-libass --enable-libbluray --enable-libfreetype --enable-libmp3lame --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libopenjpeg --enable-libopus --enable-libshine --enable-libsnappy --enable-libsoxr --enable-libtheora --enable-libtwolame --enable-libvpx --enable-libwavpack --enable-libwebp --enable-libx264 --enable-libx265 --enable-libxml2 --enable-libzimg --enable-lzma --enable-zlib --enable-gmp --enable-libvidstab --enable-libvorbis --enable-libvo-amrwbenc --enable-libmysofa --enable-libspeex --enable-libxvid --enable-libaom --enable-libmfx --enable-amf --enable-ffnvcodec --enable-cuvid --enable-d3d11va --enable-nvenc --enable-nvdec --enable-dxva2 --enable-avisynth
  libavutil      56. 18.102 / 56. 18.102
  libavcodec     58. 20.101 / 58. 20.101
  libavformat    58. 17.100 / 58. 17.100
  libavdevice    58.  4.101 / 58.  4.101
  libavfilter     7. 25.100 /  7. 25.100
  libswscale      5.  2.100 /  5.  2.100
  libswresample   3.  2.100 /  3.  2.100
  libpostproc    55.  2.100 / 55.  2.100
[apng @ 000001bc46816f80] In-stream tag=[233]_X[199] (0xC7585FE9) len=447601638 is not implemented. Update your FFmpeg version to the newest one from Git. If the problem still occurs, it means that your file has a feature which has not been implemented.
[apng @ 000001bc46816f80] If you want to help, upload a sample of this file to ftp://upload.ffmpeg.org/incoming/ and contact the ffmpeg-devel mailing list. (ffmpeg-devel@ffmpeg.org)
Input #0, apng, from '.\spinfox_cut53.png':
  Duration: N/A, start: 0.000000, bitrate: N/A
    Stream #0:0: Video: apng, rgba(pc), 148x148, 20 fps, 20 tbr, 100k tbn, 100k tbc
[apng @ 000001bc46816f80] In-stream tag=[0][0][0][0] (0x00000000) len=0 is not implemented. Update your FFmpeg version to the newest one from Git. If the problem still occurs, it means that your file has a feature which has not been implemented.
[apng @ 000001bc46816f80] If you want to help, upload a sample of this file to ftp://upload.ffmpeg.org/incoming/ and contact the ffmpeg-devel mailing list. (ffmpeg-devel@ffmpeg.org)
[apng @ 000001bc4681e5c0] chunk too big

Direct links to the files:
https://flif.info/example-animation/spinfox_cut15.png
https://flif.info/example-animation/spinfox_cut33.png
https://flif.info/example-animation/spinfox_cut53.png

screenshot of my command line
https://i.imgur.com/L1aUj4K.png

This bug report is only about the endless command line spam.
The warning is likely caused by the incomplete file (I guess) and therefore it's correct that it's shown; but it would be enough if it would be shown once.

Attachments (3)

spinfox_cut15.png (84.2 KB) - added by cehoyos 8 days ago.
spinfox_cut33.png (185.3 KB) - added by cehoyos 8 days ago.
spinfox_cut53.png (297.6 KB) - added by cehoyos 8 days ago.

Download all attachments as: .zip

Change History (5)

comment:1 Changed 8 days ago by cehoyos

  • Component changed from ffplay to avformat
  • Keywords apng added
  • Priority changed from normal to minor
  • Reproduced by developer set
  • Status changed from new to open

Patch sent, please only provide screenshots if specifically requested.

Changed 8 days ago by cehoyos

Changed 8 days ago by cehoyos

Changed 8 days ago by cehoyos

comment:2 Changed 6 days ago by cehoyos

  • Resolution set to fixed
  • Status changed from open to closed

Thank you for the report, should be fixed in 5ff080fdfa25727abffe0fcf7dc50f6e194e02fd

Note: See TracTickets for help on using tickets.