Opened 13 days ago

Closed 13 days ago

Last modified 13 days ago

#7529 closed defect (invalid)

cuda filters not compiled

Reported by: msiders Owned by:
Priority: normal Component: build system
Version: git-master Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Summary of the bug:

When compiling FFmpeg with CUDA (./configure --enable-cuda) the filters based on this library isn't automatically enabled.

See this example of a build of git-master when searching for CUDA filters:

root@ffmpeg:~/FFmpeg# ./ffmpeg -filters | grep cuda
ffmpeg version N-92330-gd6d407d Copyright (c) 2000-2018 the FFmpeg developers
  built with gcc 4.7 (Debian 4.7.2-5)
  configuration: --enable-static --disable-shared --disable-doc --disable-dxva2 --enable-small --enable-pthreads --enable-stripping --enable-bsfs --disable-devices --disable-hwaccels --disable-ffprobe --enable-gpl --enable-libx264 --enable-cuda --enable-nonfree --enable-cuvid --enable-nvenc --extra-cflags=-I/usr/local/cuda/include/ --extra-ldflags=-L/usr/local/cuda/lib64/
  libavutil      56. 23.100 / 56. 23.100
  libavcodec     58. 36.100 / 58. 36.100
  libavformat    58. 21.100 / 58. 21.100
  libavdevice    58.  6.100 / 58.  6.100
  libavfilter     7. 41.100 /  7. 41.100
  libswscale      5.  4.100 /  5.  4.100
  libswresample   3.  4.100 /  3.  4.100
  libpostproc    55.  4.100 / 55.  4.100
 ... hwupload_cuda     V->V       (null)

As you can see the "--enable-cuda" is enabled in the build. But filters like "scale_cuda" and "thumbnail_cuda" are missing. To compile them is required to enable each one in the configure call. However, it has sense to enable them automatically when CUDA_SDK is set in the configuration.

Please, fix this!

Change History (2)

comment:1 Changed 13 days ago by oromit

  • Resolution set to invalid
  • Status changed from new to closed

You have to --enable-cuda-sdk to build the filters, since they require the full proprietary CUDA SDK.

comment:2 Changed 13 days ago by msiders

Thank you, Oromit!

Note: See TracTickets for help on using tickets.