Opened 3 weeks ago

Closed 3 weeks ago

#7515 closed defect (needs_more_info)

Unexpected demuxer behavior for FFmpeg configured with "disable-decoders"

Reported by: rgadkari Owned by:
Priority: normal Component: avformat
Version: git-master Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Summary of the bug:
We are using only the demuxer functionality of FFmpeg in an application. FFmpeg has been configured with "disable-decoders" option, hence no enabled decoders are present.
When the function - avformat_find_stream_info is invoked, it further calls find_probe_decoder, but since no decoders are enabled, it causes seg-fault or unexpected behavior.

Configuration -
./configure --enable-shared --disable-encoders --disable-decoders --disable-optimizations --enable-debug --disable-stripping --enable-logging

Change History (2)

comment:1 in reply to: ↑ description Changed 3 weeks ago by cehoyos

  • Reproduced by developer unset

Replying to rgadkari:

We are using only the demuxer functionality of FFmpeg in an application. FFmpeg has been configured with "disable-decoders" option, hence no enabled decoders are present.
When the function - avformat_find_stream_info is invoked, it further calls find_probe_decoder, but since no decoders are enabled, it causes seg-fault

Please provide backtrace, disassembly and register dump and explain how I can reproduce the issue.

comment:2 Changed 3 weeks ago by cehoyos

  • Resolution set to needs_more_info
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.