Opened 2 months ago

Closed 2 months ago

#7499 closed defect (fixed)

libavformat/dump.c has a typo in dump_audioservicetype

Reported by: rogerz42892 Owned by:
Priority: minor Component: avformat
Version: git-master Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: no

Description

Summary of the bug:

Providing '-audio_service_type:a:0 5' produces the service type "comentary". It should be "commentary"

How to reproduce:

% ffmpeg -i input.mp4 -map 0:0 -map 0:1 -c:v copy -c:a ac3 -audio_service_type:a:0 5 output.mp4
% ffprobe output.mp4
....
Side data:
      audio service type: comentary

ffmpeg version 4.0.2-tessus
built on Mac OS X (John Van Sickle binary)

Patches should be submitted to the ffmpeg-devel mailing list and not this bug tracker.

Change History (2)

comment:1 Changed 2 months ago by rogerz42892

So, obviously this is not a bug in ffmpeg, but in ffprobe.

comment:2 Changed 2 months ago by cehoyos

  • Priority changed from normal to minor
  • Reproduced by developer set
  • Resolution set to fixed
  • Status changed from new to closed
  • Version changed from unspecified to git-master

Fixed in feb05ffa99fc3633e5dd97916ac67dc4e7c76ab2, thank you for the report!

Note: See TracTickets for help on using tickets.