Opened 4 weeks ago

Closed 4 weeks ago

#7492 closed defect (needs_more_info)

ffmpeg crashes when using autothreading (-threads 0)

Reported by: ofarrnbacher Owned by:
Priority: normal Component: undetermined
Version: unspecified Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Summary of the bug:
How to reproduce:

% ffmpeg -threads 0 -i input output
ffmpeg version n4.0.2
built on Ubuntu 16.04.5 LTS

Results in:
Error while filtering: Cannot allocate memory
11800 Failed to inject frame into filter network: Cannot allocate memory

If I set -threads to e.g. 8 then it works.

Happens everytime on Intel(R) Xeon(R) W-2145 CPU @ 3.70GHz

Does NOT happen on Intel(R) Core(TM) i7-3770 CPU @ 3.40GHz

Attachments (5)

ffmpeg-20181011-113543.log (1.1 MB) - added by ofarrnbacher 4 weeks ago.
ffmpeg_g -v 9 -loglevel 99
ffmpeg-test.sh (1.2 KB) - added by ofarrnbacher 4 weeks ago.
ffmpeg call with all parameters
gdb-out.log (2.0 KB) - added by ofarrnbacher 4 weeks ago.
gdb out
valgrind.log (2.1 KB) - added by ofarrnbacher 4 weeks ago.
valgrind log
valgrind.sh (1.2 KB) - added by ofarrnbacher 4 weeks ago.

Download all attachments as: .zip

Change History (8)

Changed 4 weeks ago by ofarrnbacher

ffmpeg_g -v 9 -loglevel 99

Changed 4 weeks ago by ofarrnbacher

ffmpeg call with all parameters

Changed 4 weeks ago by ofarrnbacher

gdb out

Changed 4 weeks ago by ofarrnbacher

valgrind log

Changed 4 weeks ago by ofarrnbacher

comment:1 Changed 4 weeks ago by heleppkes

You are running out of memory. While in an ideal work it should not crash and there is a bug somewhere thats not checking all failure cases somewhere, the lack of memory will always result in ffmpeg failing eventually, even if cleaner then a crash.

comment:2 Changed 4 weeks ago by richardpl

Try latest master, because you are probably hitting bug in amerge filter that have been fixed.

comment:3 Changed 4 weeks ago by cehoyos

  • Component changed from avfilter to undetermined
  • Resolution set to needs_more_info
  • Status changed from new to closed
  • Only current FFmpeg git head is supported
  • The title contradicts the log files
  • I cannot reproduce different behaviour for different number of threads
Note: See TracTickets for help on using tickets.