Opened 4 weeks ago

Closed 4 weeks ago

#7491 closed defect (fixed)

aac crashes with gcc 8.2 lto

Reported by: Hello71 Owned by:
Priority: important Component: avcodec
Version: git-master Keywords: aac crash
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Summary of the bug:

it doesn't work.

How to reproduce:

  1. build ffmpeg with gcc 8.2 + lto and hardcoded tables
  2. play aac file

expected results:

it works

actual results:

it crashes in ff_sine_window_init

additional information:

https://gcc.gnu.org/bugzilla/show_bug.cgi?id=85132

(this is not my report but seems to be the same bug)

Change History (3)

comment:1 Changed 4 weeks ago by cehoyos

  • Priority changed from normal to important
  • Version changed from unspecified to git-master

Does the following change fix the crash for you?

diff --git a/libavcodec/sinewin.h b/libavcodec/sinewin.h
index 6b97a71..a0802ac 100644
--- a/libavcodec/sinewin.h
+++ b/libavcodec/sinewin.h
@@ -26,7 +26,7 @@
 #include "libavcodec/aac_defines.h"

 #if CONFIG_HARDCODED_TABLES
-#   define SINETABLE_CONST const
+#   define SINETABLE_CONST
 #else
 #   define SINETABLE_CONST
 #endif

comment:2 Changed 4 weeks ago by Hello71

seems to work

comment:3 Changed 4 weeks ago by cehoyos

  • Keywords aac crash added
  • Resolution set to fixed
  • Status changed from new to closed

Should be fixed in 10f468156c0109a06854b5d672c5209a88923ce9, thank you for the report!

Note: See TracTickets for help on using tickets.