Opened 2 months ago

Closed 7 weeks ago

#7478 closed defect (invalid)

ERROR: vorbis not found using pkg-config

Reported by: serverok Owned by: hspedro
Priority: normal Component: ffmpeg
Version: git-master Keywords: libvorbis
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: yes

Description

https://trac.ffmpeg.org/login
serverok
eaBXmrjwUN@S2U

Summary of the bug: ERROR: vorbis not found using pkg-config
How to reproduce:

Configure fail with the error.

git clone  https://github.com/FFmpeg/FFmpeg
cd FFmpeg
./configure --prefix=/usr --enable-shared --enable-libxvid --enable-libvorbis --enable-libtheora --enable-libmp3lame --enable-gpl --enable-libfdk-aac --enable-nonfree --enable-libx264 --enable-libfreetype

I already installed vorbis with command

cd /usr/local/src/
wget -c http://downloads.xiph.org/releases/vorbis/libvorbis-1.3.6.tar.gz
tar zxvf libvorbis-1.3.6.tar.gz
cd /usr/local/src/libvorbis-1.3.6
./configure && make && make install

Attachments (1)

config.log (368.6 KB) - added by serverok 2 months ago.
ffbuild/config.log

Download all attachments as: .zip

Change History (7)

Changed 2 months ago by serverok

ffbuild/config.log

comment:1 Changed 2 months ago by serverok

Sorry, i pasted my login info here, since i can't edit the issue, i changed password, ignore that part.

comment:2 Changed 7 weeks ago by hspedro

Hi @serverok,

From your config.log, the issue seems to be that pkg-config did not found a vorbis
pkg on your system. Generally, the libraries come with a .pc file that indicates to
pkg-config necessary variables. This vorbis.pc file should be copied to pkg-config path
during make install. I ran your procedure and that was the case for me:


180 make[2]: Nothing to be done for 'install-exec-am'.
181 /bin/mkdir -p '/usr/local/share/aclocal'
182 /usr/bin/install -c -m 644 vorbis.m4 '/usr/local/share/aclocal'
183 /bin/mkdir -p '/usr/local/lib/pkgconfig'
184 /usr/bin/install -c -m 644 vorbis.pc vorbisenc.pc vorbisfile.pc '/usr/local/lib/pkgconfig'


Check if during your make install this procedure was executed. You could also check
with pkg-config --exists --print-errors vorbis && echo $?, if it returns 0 then vorbis
was found by pkg-config.

In anyway this doesn't seem to be a problem in ffmpeg itself.

comment:3 Changed 7 weeks ago by hspedro

  • Analyzed by developer set
  • Owner set to hspedro
  • Status changed from new to open

comment:4 Changed 7 weeks ago by jamrial

If you installed libvorbis to /usr/local, then you should tell pkg-config to look for it there.

Try using PKG_CONFIG_PATH="/usr/local/lib/pkgconfig" as environment variable when running configure.

comment:5 Changed 7 weeks ago by serverok

I reinstalled libvorbis with prefix /usr, but

pkg-config --exists --print-errors vorbis

Failed. Same for x264. One i set

export PKG_CONFIG_PATH="/usr/lib/pkgconfig"

It worked.

comment:6 Changed 7 weeks ago by jamrial

  • Resolution set to invalid
  • Status changed from open to closed
Note: See TracTickets for help on using tickets.