Opened 2 weeks ago

Closed 2 weeks ago

#7467 closed enhancement (invalid)

ffmpeg mkv muxer missing track statistics

Reported by: eliz82 Owned by:
Priority: normal Component: undetermined
Version: unspecified Keywords: mkv handbrake
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Summary of the bug:
This ticket is coming from original post written here:
https://github.com/HandBrake/HandBrake/issues/1609

It seems Handbrake encoding app is using ffmpeg as a muxer for mkv files (?)
Some statistics (like video & audio bit rate) will be missing from the metadata of the resulted mkv file.

Other encoding apps that are using libmatroska to mux have those statistics (see printscreen in my original post).

Here is the source code of the matroska lib that generate track stats:
https://gitlab.com/mbunkus/mkvtoolnix/blob/master/src/common/track_statistics.cpp
https://gitlab.com/mbunkus/mkvtoolnix/blob/master/src/common/track_statistics.h

Change History (1)

comment:1 Changed 2 weeks ago by cehoyos

  • Keywords handbrake added; statistics removed
  • Resolution set to invalid
  • Status changed from new to closed

Please reopen this ticket if the issue is reproducible with current FFmpeg git head and if you can provide the command line you tested together with the complete, uncut console output.
Please do not use external resources except for necessary large input files.

Note: See TracTickets for help on using tickets.