Opened 3 months ago

Closed 3 months ago

Last modified 3 months ago

#7451 closed defect (invalid)

mjpeg movies have lifted black

Reported by: fnordware Owned by:
Priority: normal Component: undetermined
Version: unspecified Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Summary of the bug: If I start with a PNG sequence or ProRes? movie that has areas of black pixels and transcode to mjpeg, the black areas are not quite black. This can be verified by converting the mjpeg movie back to PNG.

How to reproduce:

% ffmpeg -i  -start_number 0 -framerate 30.0 -i input.%03d.png -c:v mjpeg -q 3 output.mov

% ffmpeg -i output.mov verify.%03d.png


ffmpeg version 4.0.2-tessus Copyright (c) 2000-2018 the FFmpeg developers
  built with Apple LLVM version 9.1.0 (clang-902.0.39.2)

Change History (2)

comment:1 Changed 3 months ago by cehoyos

  • Component changed from avcodec to undetermined
  • Keywords mjpeg removed
  • Resolution set to invalid
  • Status changed from new to closed

You cannot convert png->jpg->png and expect identical output.

If this is a regression please also test current FFmpeg git head, test with the color filter and provide your command line together with the complete, uncut console output to make this a valid ticket.

comment:2 Changed 3 months ago by fnordware

I realize there will be some loss going from PNG to mjpeg, but I still expect large black areas to stay black.

BUT...it seems to be fixed in the latest build, N-91991-gc02ff77681-tessus. Sorry about the needless trouble.

Note: See TracTickets for help on using tickets.