Opened 3 months ago

Closed 3 months ago

#7447 closed defect (duplicate)

Decoding ogg (vorbis) appends extra samples to output

Reported by: evesira Owned by:
Priority: normal Component: undetermined
Version: unspecified Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Summary of the bug:

ffmpeg incorrectly decodes ogg (vorbis) files, appending extra samples at the end of the audio output. The amount of samples added doesn't seem to be correlated to file size or anything else. The added samples seem to always be digital silence.

This ticket stemmed from this issue reported in the Chrome browser:
https://bugs.chromium.org/p/chromium/issues/detail?id=884526#c10

This issue causes the inability to seamlessly and correctly loop layered and synced ogg tracks of the same exact length after they have been decoded by ffmpeg.

Vorbis was designed to be capable of sample-perfect looping, so being able to reconstruct the file exactly is possible and necessary.

How to reproduce:

% ffmpeg -i test.ogg test.wav
ffmpeg version: ffmpeg-20180919-e33b28c-win64-static (Zeranoe)

Test ogg file:
https://instaud.io/_/2HtN.ogg
input file is exactly 6.00 seconds long, or 264,600 samples at 44.1 kHz
output file is 265,536 samples long, 936 samples added

Other softwares that support loading of oggs, such as Audacity, Wavosaur, Ocen, etc (which presumably use libvorbis and not ffmpeg), correctly decode the test file as 264,600 samples long.

Change History (1)

comment:1 Changed 3 months ago by cehoyos

  • Resolution set to duplicate
  • Status changed from new to closed

Sounds like a duplicate of ticket #6367.

Note: See TracTickets for help on using tickets.