Opened 2 months ago

Closed 2 months ago

Last modified 2 months ago

#7439 closed defect (fixed)

VP9 level is not computed correctly in VP9 codec configuration (mp4)

Reported by: kqyang Owned by: kqyang
Priority: normal Component: avformat
Version: git-master Keywords: vp9
Cc: Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: yes

Description

Summary of the bug:
How to reproduce:

% ffmpeg -i input -c:v libvpx-vp9 -profile:v 0 -level 2.1 -vf scale=640:-2 output
ffmpeg version N-91941-gf3b430e0e4 Copyright (c) 2000-2018 the FFmpeg developers
  built with gcc 7 (Debian 7.3.0-5)    
  ...

The VPCodecConfigurationRecord in the output file contains a level of 0x21. It should be 21 instead. See https://www.webmproject.org/vp9/mp4/.

I am working on the fix.

Change History (10)

comment:2 Changed 2 months ago by kqyang

  • Owner set to kqyang
  • Status changed from new to open

comment:1 Changed 2 months ago by kqyang

  • Owner set to kqyang
  • Status changed from new to open

comment:2 Changed 2 months ago by kqyang

The problem is discovered when working on https://github.com/google/shaka-packager/issues/469.

comment:3 Changed 2 months ago by kqyang

The problem is discovered when working on https://github.com/google/shaka-packager/issues/469.

comment:4 follow-ups: Changed 2 months ago by heleppkes

This should've been fixed earlier today in 63c69d51c7532fb6c2460076329b50ec51a0f290

comment:5 Changed 2 months ago by jamrial

  • Keywords vp9 mp4 added; VP9 Level removed
  • Resolution set to fixed
  • Status changed from open to closed

This was indeed fixed a few minutes before this ticket was created.

comment:6 in reply to: ↑ 4 Changed 2 months ago by kqyang

Replying to heleppkes:

This should've been fixed earlier today in 63c69d51c7532fb6c2460076329b50ec51a0f290

Oh, cool. Thanks for the quick update!

comment:7 in reply to: ↑ 4 Changed 2 months ago by kqyang

Will the fix be included in the upcoming FFMpeg v4.1 release?

comment:8 Changed 2 months ago by heleppkes

Yes.

comment:9 Changed 2 months ago by cehoyos

  • Keywords mp4 removed
Note: See TracTickets for help on using tickets.