Opened 12 days ago

Closed 11 days ago

#7433 closed defect (fixed)

libaomenc.c: undeclared symbol AOM_ERROR_RESILIENT_PARTITIONS

Reported by: LigH Owned by:
Priority: normal Component: avcodec
Version: git-master Keywords: libaom
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Building ffmpeg with libaom fails in libavcodec/libaomenc.c:744:109: error: 'AOM_ERROR_RESILIENT_PARTITIONS' undeclared here (not in a function); did you mean 'AOM_ERROR_RESILIENT_DEFAULT'?

                          " is still done over the partition boundary.",       0, AV_OPT_TYPE_CONST, {.i64 = AOM_ERROR_RESILIENT_PARTITIONS}, 0, 0, VE, "er"},
                                                                                                             ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
                                                                                                             AOM_ERROR_RESILIENT_DEFAULT

Attached archive of logs and other diagnostic files was generated by media-autobuild_suite (running in MSYS2/MinGW)

Attachments (1)

logs.zip (214.7 KB) - added by LigH 12 days ago.
MABS logs and diagnostics archive

Download all attachments as: .zip

Change History (7)

Changed 12 days ago by LigH

MABS logs and diagnostics archive

comment:1 Changed 12 days ago by Cubittus

I too see this issue with libaom git master head.

It is due to this libaom commit yesterday: 'Remove vestigial VP8 token partition support.'

https://aomedia.googlesource.com/aom/+/df4ffb73140fe31bebdabd17c1a7b53721e74838%5E%21/

comment:2 Changed 12 days ago by LigH

Added a reply to their code review 70421.

comment:3 Changed 12 days ago by cehoyos

  • Keywords libaom added

comment:4 Changed 12 days ago by cehoyos

For future tickets: Please do not attach compressed logs, instead provide the simplified configure line you tested, run make V=1 twice and post the console output of the second run here. (Never post the console output of the first run.)

comment:5 Changed 11 days ago by jamrial

  • Resolution set to fixed
  • Status changed from new to closed

comment:6 Changed 11 days ago by heleppkes

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.