Opened 10 months ago

Closed 5 months ago

Last modified 5 months ago

#7406 closed defect (needs_more_info)

[ffmpeg-qsv][vc1_decode]dump file has garbage on iHD driver.

Reported by: zhuqingliang Owned by:
Priority: normal Component: undetermined
Version: unspecified Keywords: qsv
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Summary of the bug:

the dump file has mosaic

environment

SKL OS: ubuntu 16.04 kernel: 4.15.0 
libva b6c50dad4d7d14c507108d9f468662e2d7ae1c4d ​https://github.com/01org/libva.git 
VPG_Driver ed04556a6676fd77ff845508bc54bfc60915450c ​https://github.com/intel/media-driver
libva-utils 9a10ad663349732decd668a426cfc349b0010d1d ​https://github.com/01org/libva-utils.git
Mediasdk 7ea683585f0f84f1bea035a405855312c92c46c0 ​https://github.com/Intel-Media-SDK/MediaSDK
FFMPEG 56f68a099cc607658118e00cad30569103ae3751 ​https://git.ffmpeg.org/ffmpeg.git

How to reproduce:

1.build env as above lists
2.ffmpeg -hwaccel qsv -hwaccel_device /dev/dri/renderD128 -v verbose -c:v vc1_qsv -i /media//yami_vc1/SA10097.vc1 -vf hwdownload,format=nv12 -pix_fmt yuv420p -f rawvideo -vsync 0 -y ./dump.yuv
3. 7yuv open dump.yuv

Attachments (2)

SA10097.PNG (656.8 KB) - added by zhuqingliang 10 months ago.
SA10097.vc1 (399.5 KB) - added by cehoyos 10 months ago.

Download all attachments as: .zip

Change History (6)

Changed 10 months ago by zhuqingliang

comment:1 Changed 10 months ago by cehoyos

  • Keywords decode removed

comment:2 Changed 10 months ago by jkqxz

Please share the input file.

Changed 10 months ago by cehoyos

comment:3 Changed 5 months ago by zhuqingliang

  • Resolution set to fixed
  • Status changed from new to closed

can't reproduce on latest code.

comment:4 Changed 5 months ago by cehoyos

  • Resolution changed from fixed to needs_more_info

Please add the commit that fixed the issue.

Note: See TracTickets for help on using tickets.