Opened 11 months ago

Closed 5 months ago

Last modified 5 months ago

#7397 closed defect (needs_more_info)

[ffmpeg-qsv][h264_ffmpeg]decode dump file has garbage on iHD driver.

Reported by: zhuqingliang Owned by:
Priority: normal Component: undetermined
Version: unspecified Keywords: qsv
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Summary of the bug:
How to reproduce:

1.ffmpeg -hwaccel qsv -hwaccel_device /dev/dri/renderD128 -v verbose -y -c:v h264_qsv -i /media//ffmpeg_h264/crop-to-container-dims-canon.mov -vf hwdownload,format=nv12 -pix_fmt yuv420p -f rawvideo -y dump.yuv -vsync 0
2. 7yuv to open dump.yuv
ffmpeg version : N-91726-g56f68a0

bug descript

The dump file md5 is not equal to reference, and the dump file has garbage.

Attachments (1)

crop-to-container-dims-canon.mov (524.1 KB) - added by zhuqingliang 11 months ago.

Download all attachments as: .zip

Change History (10)

Changed 11 months ago by zhuqingliang

comment:1 Changed 11 months ago by zhuqingliang

  • Summary changed from ffmpeg qsv h264 decode dump file has garbage on iHD driver. to [ffmpeg-qsv][h264_ffmpeg]decode dump file has garbage on iHD driver.

comment:2 Changed 11 months ago by zhuqingliang

failed case

/media/ffmpeg_h264/crop-to-container-dims-canon.mov
/media/ffmpeg_h264/H264_might_overflow.mkv

comment:3 Changed 11 months ago by cehoyos

  • Keywords qsv added; ffmpeg-qsv h264 decode removed

comment:5 Changed 11 months ago by cehoyos

  • Keywords qsv added; ffmpeg-qsv h264 decode removed

comment:6 Changed 10 months ago by jkqxz

This seems to work for me? Or at least, I don't get garbage in the output.

It isn't bit-exact because the input is full-range and libmfx doesn't seem to have any way of communicating that, but the data is correct. (Decoding with iHD directly via VAAPI supports the range signalling and therefore matches software behaviour exactly, so this is only a libmfx problem.)

comment:7 Changed 10 months ago by fulinjie

Tested with the latest version of MSDK: c083a2724b99851af6d69bbb35e3130b39a1f702

$ ffmpeg -i crop-to-container-dims-canon.mov -c:v copy src.h264
$ ./sample_decode h264 -i src.h264 -i420 -o msdk.yuv
ffmpeg -hwaccel qsv -hwaccel_device /dev/dri/renderD128 -v verbose -y -c:v h264_qsv -i crop-to-container-dims-canon.mov -vf hwdownload,format=nv12 -pix_fmt yuv420p -f rawvideo -y dump.yuv -vsync 0

Both msdk.yuv and dump.yuv have garbage in my test.

Report an issue in MediaSDK:
https://github.com/Intel-Media-SDK/MediaSDK/issues/715

comment:8 Changed 5 months ago by zhuqingliang

  • Resolution set to fixed
  • Status changed from new to closed

dump.yuv don't have garbage on latest code base.

comment:9 Changed 5 months ago by cehoyos

  • Resolution changed from fixed to needs_more_info

Please add the commit that fixed the issue.

Note: See TracTickets for help on using tickets.