Opened 8 months ago

Closed 8 months ago

#7389 closed defect (duplicate)

ffmpeg/ffprobe/ffplay fails to handle some mp4 videos properly

Reported by: KTSamy Owned by:
Priority: important Component: avformat
Version: git-master Keywords: mov regression
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Sample Video: https://drive.google.com/open?id=1apvJLSYvhapoGNztuo2oVbzfAXnNQBL9

Inspect the sample file using ffprobe (-show_frames) or use ffmpeg to stream copy the file or try to play the file using ffplay.

Regression Since: 4a9d32baca3af0d1831f9556a922c7ab5b426b10

Result:
Several packets are not read by the latest ffmpeg. You can notice that there are no packets between 5secs and 24secs.

I have attached the ffprobe's -show_frames data from ffmpeg 3.2.4 and master for quicker reference.

Attachments (3)

frames_master.txt.7z (693.0 KB) - added by KTSamy 8 months ago.
frames_3.2.4.txt 1.7z.001 (2.0 MB) - added by KTSamy 8 months ago.
Frame Data from 3.2.4
frames_3.2.4.txt 1.7z.002 (1.3 MB) - added by KTSamy 8 months ago.
Frame Data from 3.2.4 (Part II)

Change History (5)

Changed 8 months ago by KTSamy

Changed 8 months ago by KTSamy

Frame Data from 3.2.4

Changed 8 months ago by KTSamy

Frame Data from 3.2.4 (Part II)

comment:1 Changed 8 months ago by KTSamy

When ffplay is used, it just jumps from 5 secs to 24secs. When using the seek right after that, it freezes. Has to be force closed using ctrl+c on the terminal.

comment:2 Changed 8 months ago by cehoyos

  • Keywords mov regression added
  • Priority changed from normal to important
  • Resolution set to duplicate
  • Status changed from new to closed

Looks like a duplicate of ticket #7377.

Note: See TracTickets for help on using tickets.