Opened 11 months ago

Closed 11 months ago

Last modified 11 months ago

#7320 closed defect (invalid)

avformat_find_stream_info(), audio=virtual-audio-capturer, block.

Reported by: donview Owned by:
Priority: normal Component: undetermined
Version: unspecified Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

ffmpeg started on 2018-07-19 at 12:04:16
Report written to "ffmpeg-20180719-120416.log"
Command line:
ffmpeg.exe -report -f dshow -i "audio=virtual-audio-capturer" -f dshow -i "video=screen-capture-recorder" -vcodec libx264 -acodec aac -s "1920*1080" -r 25 -g 25 -pix_fmt yuv420p -preset veryfast -tune zerolatency "C:
Users
SevenZoe?
Desktop
FFmpeg_Bat_Bin
out.mp4"
ffmpeg version 4.0.1 Copyright (c) 2000-2018 the FFmpeg developers

built with gcc 7.3.1 (GCC) 20180710
configuration: --enable-gpl --enable-version3 --enable-sdl2 --enable-bzlib --enable-fontconfig --enable-gnutls --enable-iconv --enable-libass --enable-libbluray --enable-libfreetype --enable-libmp3lame --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libopenjpeg --enable-libopus --enable-libshine --enable-libsnappy --enable-libsoxr --enable-libtheora --enable-libtwolame --enable-libvpx --enable-libwavpack --enable-libwebp --enable-libx264 --enable-libx265 --enable-libxml2 --enable-libzimg --enable-lzma --enable-zlib --enable-gmp --enable-libvidstab --enable-libvorbis --enable-libvo-amrwbenc --enable-libmysofa --enable-libspeex --enable-libxvid --enable-libaom --enable-libmfx --enable-amf --enable-ffnvcodec --enable-cuvid --enable-d3d11va --enable-nvenc --enable-nvdec --enable-dxva2 --enable-avisynth
libavutil 56. 14.100 / 56. 14.100
libavcodec 58. 18.100 / 58. 18.100
libavformat 58. 12.100 / 58. 12.100
libavdevice 58. 3.100 / 58. 3.100
libavfilter 7. 16.100 / 7. 16.100
libswscale 5. 1.100 / 5. 1.100
libswresample 3. 1.100 / 3. 1.100
libpostproc 55. 1.100 / 55. 1.100

Splitting the commandline.
Reading option '-report' ... matched as option 'report' (generate a report) with argument '1'.
Reading option '-f' ... matched as option 'f' (force format) with argument 'dshow'.
Reading option '-i' ... matched as input url with argument 'audio=virtual-audio-capturer'.
Reading option '-f' ... matched as option 'f' (force format) with argument 'dshow'.
Reading option '-i' ... matched as input url with argument 'video=screen-capture-recorder'.
Reading option '-vcodec' ... matched as option 'vcodec' (force video codec ('copy' to copy stream)) with argument 'libx264'.
Reading option '-acodec' ... matched as option 'acodec' (force audio codec ('copy' to copy stream)) with argument 'aac'.
Reading option '-s' ... matched as option 's' (set frame size (WxH or abbreviation)) with argument '1920*1080'.
Reading option '-r' ... matched as option 'r' (set frame rate (Hz value, fraction or abbreviation)) with argument '25'.
Reading option '-g' ... matched as AVOption 'g' with argument '25'.
Reading option '-pix_fmt' ... matched as option 'pix_fmt' (set pixel format) with argument 'yuv420p'.
Reading option '-preset' ... matched as AVOption 'preset' with argument 'veryfast'.
Reading option '-tune' ... matched as AVOption 'tune' with argument 'zerolatency'.
Reading option 'C:\Users\SevenZoe?\Desktop\FFmpeg_Bat_Bin\out.mp4' ... matched as output url.
Finished splitting the commandline.
Parsing a group of options: global .
Applying option report (generate a report) with argument 1.
Successfully parsed a group of options.
Parsing a group of options: input url audio=virtual-audio-capturer.
Applying option f (force format) with argument dshow.
Successfully parsed a group of options.
Opening an input file: audio=virtual-audio-capturer.
[dshow @ 06295700] Selecting pin Capture Pin on audio only

Received windows signal 2
[dshow @ 06295700] interrupted
Guessed Channel Layout for Input Stream #0.0 : stereo
Input #0, dshow, from 'audio=virtual-audio-capturer':

Duration: N/A, bitrate: N/A

Stream #0:0, 0, 1/10000000: Audio: pcm_s16le, 48000 Hz, stereo, s16, 1536 kb/s

Successfully opened the file.
Parsing a group of options: input url video=screen-capture-recorder.
Applying option f (force format) with argument dshow.
Successfully parsed a group of options.
Opening an input file: video=screen-capture-recorder.
[dshow @ 0629ef40] Selecting pin Capture on video
[dshow @ 0629ef40] interrupted
Input #1, dshow, from 'video=screen-capture-recorder':

Duration: N/A, bitrate: N/A

Stream #1:0, 0, 1/10000000: Video: rawvideo, bgr0, 2560x1440, 30 fps, 30 tbr, 10000k tbn, 10000k tbc

Successfully opened the file.
Parsing a group of options: output url C:\Users\SevenZoe?\Desktop\FFmpeg_Bat_Bin\out.mp4.
Applying option vcodec (force video codec ('copy' to copy stream)) with argument libx264.
Applying option acodec (force audio codec ('copy' to copy stream)) with argument aac.
Applying option s (set frame size (WxH or abbreviation)) with argument 1920*1080.
Applying option r (set frame rate (Hz value, fraction or abbreviation)) with argument 25.
Applying option pix_fmt (set pixel format) with argument yuv420p.
Successfully parsed a group of options.
Opening an output file: C:\Users\SevenZoe?\Desktop\FFmpeg_Bat_Bin\out.mp4.
dshow passing through packet of type video size 29491254 timestamp 78809110000 orig timestamp 78809110000 graph timestamp 78809110000 diff 0 screen-capture-recorder
dshow passing through packet of type video size 29491254 timestamp 78809710000 orig timestamp 78809710000 graph timestamp 78809710000 diff 0 screen-capture-recorder
[dshow @ 0629ef40] real-time buffer [screen-capture-recorder] [video input] too full or near too full (969% of size: 3041280 [rtbufsize parameter])! frame dropped!
dshow passing through packet of type video size 29491254 timestamp 78810410000 orig timestamp 78810410000 graph timestamp 78810410000 diff 0 screen-capture-recorder
[dshow @ 0629ef40] real-time buffer [screen-capture-recorder] [video input] too full or near too full (969% of size: 3041280 [rtbufsize parameter])! frame dropped!
dshow passing through packet of type video size 29491254 timestamp 78811080000 orig timestamp 78811080000 graph timestamp 78811080000 diff 0 screen-capture-recorder
[dshow @ 0629ef40] real-time buffer [screen-capture-recorder] [video input] too full or near too full (969% of size: 3041280 [rtbufsize parameter])! frame dropped!


I found this problem because my program is not working, After forcibly updating Windows10(Windows version:1803, os internal version 17134.1).

audio=virtual-audio-capturer
avformat_open_input();
ok
avformat_find_stream_info(); block

I suspect that there is a problem with my program.
Then, I go to your official website and download the latest ffmpeg.exe, run directly, and found to be problematic.

note, note, note, note, note:

If I open the windows control panel, select any one of the installed programs, any one, right click and uninstall. At this point, the operating system will pop up a dialog box asking if I want to uninstall. Then the magic scene appears, avformat_find_stream_info() does not block.

In fact, after I right-clicked on the uninstall, I didn't have any operations. I didn't choose to uninstall, and I didn't choose to cancel it. I didn't choose to close the pop-up dialog box. But avformat_find_stream_info() is really not blocked.

Visual studio 2017 breakpoint debugging.

Never encountered before, it is after the mandatory update of windows10.

Change History (3)

comment:1 Changed 11 months ago by donview

  • Resolution set to fixed
  • Status changed from new to closed

Solution:Select Sound Recording, enable Stereo Mix, then right click on Properties -> Listen, check the box to listen to this device.https://trac.ffmpeg.org/wiki/WikiFormatting

comment:2 Changed 11 months ago by cehoyos

  • Analyzed by developer unset
  • Component changed from avformat to undetermined
  • Keywords api block removed
  • Reproduced by developer unset

comment:3 Changed 11 months ago by cehoyos

  • Resolution changed from fixed to invalid
Note: See TracTickets for help on using tickets.