Opened 3 months ago

Closed 3 months ago

#7284 closed defect (duplicate)

Converting from .WAV (PCM) to .MP4 with -acodec copy produces unplayable output

Reported by: death Owned by:
Priority: normal Component: undetermined
Version: unspecified Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

% ffmpeg -i somewav.wav -acodec copy output.mp4
ffmpeg version 4.0-tessus Copyright (c) 2000-2018 the FFmpeg developers
  built with Apple LLVM version 9.1.0 (clang-902.0.39.1)
(...)

The produced file cannot be decoded by FFmpeg:

% ffmpeg -i output.mp4 decoded.wav
(...)
Decoder (codec none) not found for input stream #0:0

Additionally, nonsensical info appears to be written to MP4 headers regarding the channel count in the stream, the MP4 file sourced from a mono WAV has this:

Stream #0:0(und): Audio: none ([1][0][0][0] / 0x0001), 11025 Hz, stereo (default)

Yet the data within it is most definitely mono.

Attachments (2)

bleat.mp4 (65.3 KB) - added by death 3 months ago.
Example MP4 file
bleat.wav (64.7 KB) - added by death 3 months ago.
Source file that the provided example MP4 was converted from

Download all attachments as: .zip

Change History (4)

Changed 3 months ago by death

Example MP4 file

Changed 3 months ago by death

Source file that the provided example MP4 was converted from

comment:1 Changed 3 months ago by Gyan

FFmpeg does not mux PCM into MP4; MOV works.

The bug here is that ffmpeg doesn't abort with a warning like it does when the audio is being transcoded to PCM and muxed into MP4.

comment:2 Changed 3 months ago by cehoyos

  • Resolution set to duplicate
  • Status changed from new to closed

I believe this is a duplicate of ticket #6897.

For future tickets: Please test current FFmpeg git head, nothing else is supported here, and please provide the command line that allows to reproduce the issue together with the complete, uncut console output.

Note: See TracTickets for help on using tickets.