Opened 4 weeks ago

Closed 4 weeks ago

#7232 closed defect (invalid)

hevc_nvenc: Cannot get the preset configuration: invalid version (15)

Reported by: tdname Owned by:
Priority: important Component: undetermined
Version: unspecified Keywords: nvenc regression
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Summary of the bug:
I tried to update FFMPEG from 3.4 to 4.0 (or last Nightly) but the same command-line doesn't work in newer versions.
The errore is: Cannot get the preset configuration: invalid version (15)
How to reproduce:

ffmpeg -report -r 24 -c:v h264_cuvid -i "Film.mkv" -map 0:v:0 -c:v hevc_nvenc -preset hq -b:v 3.0M -r 24 -f matroska -map 0:a:0 -c:a copy -map 0:s:0 -c:s copy "Film HEVC.mkv"
ffmpeg started on 2018-05-27 at 21:07:48
Report written to "ffmpeg-20180527-210748.log"
ffmpeg version 4.0 Copyright (c) 2000-2018 the FFmpeg developers
  built with gcc 7.3.0 (GCC)
  configuration: --enable-gpl --enable-version3 --enable-sdl2 --enable-bzlib --enable-fontconfig --enable-gnutls --enable-iconv --enable-libass --enable-libbluray --enable-libfreetype --enable-libmp3lame --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libopenjpeg --enable-libopus --enable-libshine --enable-libsnappy --enable-libsoxr --enable-libtheora --enable-libtwolame --enable-libvpx --enable-libwavpack --enable-libwebp --enable-libx264 --enable-libx265 --enable-libxml2 --enable-libzimg --enable-lzma --enable-zlib --enable-gmp --enable-libvidstab --enable-libvorbis --enable-libvo-amrwbenc --enable-libmysofa --enable-libspeex --enable-libxvid --enable-libaom --enable-libmfx --enable-amf --enable-ffnvcodec --enable-cuvid --enable-d3d11va --enable-nvenc --enable-nvdec --enable-dxva2 --enable-avisynth
  libavutil      56. 14.100 / 56. 14.100
  libavcodec     58. 18.100 / 58. 18.100
  libavformat    58. 12.100 / 58. 12.100
  libavdevice    58.  3.100 / 58.  3.100
  libavfilter     7. 16.100 /  7. 16.100
  libswscale      5.  1.100 /  5.  1.100
  libswresample   3.  1.100 /  3.  1.100
  libpostproc    55.  1.100 / 55.  1.100

Attachments (1)

ffmpeg-20180527-205008_logs.zip (18.8 KB) - added by tdname 4 weeks ago.
A ZIP containing three logs/reports for ffmpeg3.4, ffmpeg4.0 and ffmpeg_nightly versions

Download all attachments as: .zip

Change History (7)

Changed 4 weeks ago by tdname

A ZIP containing three logs/reports for ffmpeg3.4, ffmpeg4.0 and ffmpeg_nightly versions

comment:1 follow-up: Changed 4 weeks ago by cehoyos

  • Component changed from ffmpeg to undetermined
  • Keywords nvenc regression added; hevc_nvenc removed
  • Version set to unspecified

Is a specific input file required or is the issue also reproducible with testsrc?
Please test git current FFmpeg git head, provide the failing command line together with the complete, uncut console output and use git bisect to find the commit introducing the issue.

comment:2 in reply to: ↑ 1 Changed 4 weeks ago by tdname

Replying to cehoyos:

Is a specific input file required or is the issue also reproducible with testsrc?

I'm not a developer and I don't know what "testsrc" is. I tried to know more about it but I havn't found something useful.
However I tried many other input files (mkv containers or single h264 raw files) that I already have converted successfully using ffmpeg_3.4 but I had no luck using newer ffmpeg versions, so it shouldn't depend of what input file is used.

Please test git current FFmpeg git head, provide the failing command line together with the complete, uncut console output and use git bisect to find the commit introducing the issue.

I'm using pre-built versions on my Windows 10 64 bit because I have no time to set the environment to build it and to use GIT commands.

I just was interested to signal a BUG.

comment:3 Changed 4 weeks ago by tdname

I already attached a ZIP file containing three UNCUTTED log/report files generated using the "-report" attribute of ffmpeg using v3.4, v4.0 and the last Nightly.

comment:4 follow-up: Changed 4 weeks ago by oromit

What version of nvidia-drivers are you using, and what version of the nv-codec-headers was your ffmpeg built with?

comment:5 in reply to: ↑ 4 Changed 4 weeks ago by tdname

Replying to oromit:

What version of nvidia-drivers are you using?

nVidia Drivers: 389.27 WHQL (17 April 2018) updated few minutes ago using Win10 "Device Manager -> Update Drivers" manual procedure.

What version of the nv-codec-headers was your ffmpeg built with?

I don't know.
I just downloaded FFMPEG 4.0 using official download link (https://ffmpeg.zeranoe.com/builds/) and selecting "Version: 4.0" - "Architecture:Windows 64 bit" - "Linking: Static"

comment:6 Changed 4 weeks ago by oromit

  • Resolution set to invalid
  • Status changed from new to closed

There are no official builds, but I assume Zeranoe uses the latest 8.1 headers.
Those require a minimum driver version of 390.77.
Kinda surprised your old drivers report 8.1 support, but clearly don't have it.

Anyway, not an ffmpeg issue. Update your drivers or build ffmpeg with 8.0 headers if you for some reason need older drivers.

Note: See TracTickets for help on using tickets.