Opened 5 months ago

Closed 5 months ago

#7228 closed defect (fixed)

The codec option 'sc_factor' disappeared from the libavcodec 4.0

Reported by: strezen Owned by:
Priority: minor Component: documentation
Version: git-master Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: no

Description

The encoding option 'sc_factor' which was available in ffmpeg 3.x now disappeared but still being referenced in the documentation (see doc/codecs.texi file):

$ ./ffmpeg -i input.mkv -sc_factor 4 -c:v mpeg2video -f mpeg2video output.m2v
ffmpeg version N-91151-g50df4c958b Copyright (c) 2000-2018 the FFmpeg developers
  built with gcc 7 (Debian 7.3.0-19)
  configuration: 
  libavutil      56. 18.102 / 56. 18.102
  libavcodec     58. 19.102 / 58. 19.102
  libavformat    58. 16.100 / 58. 16.100
  libavdevice    58.  4.100 / 58.  4.100
  libavfilter     7. 24.100 /  7. 24.100
  libswscale      5.  2.100 /  5.  2.100
  libswresample   3.  2.100 /  3.  2.100
Unrecognized option 'sc_factor'.
Error splitting the argument list: Option not found

but:

@item sc_factor @var{integer} (@emph{encoding,video})
Set value multiplied by qscale for each frame and added to
scene_change_score.

So it either was dropped or replaced with some other encoding option but this change wasn't properly documented so old scripts using that option now fail. In any case there is a discrepancy between source code and documentation.

Best regards,
Andrey

Change History (1)

comment:1 Changed 5 months ago by cehoyos

  • Component changed from undetermined to documentation
  • Keywords sc_factor removed
  • Priority changed from normal to minor
  • Reproduced by developer set
  • Resolution set to fixed
  • Status changed from new to closed

The option was disabled since 2013, documentation issue fixed in 7c333dc6a7fe1dc991f484c70ed7990d6ee62724

Note: See TracTickets for help on using tickets.