Opened 8 days ago

Closed 8 days ago

Last modified 8 days ago

#7204 closed enhancement (wontfix)

Integration of Turing Codec (HEVC encoder)

Reported by: fantesy Owned by:
Priority: wish Component: avcodec
Version: git-master Keywords: HEVC
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

At the moment the only software HEVC encoder ffmpeg uses is libx265, and i don't know if you want to keep it that way, but in 2016 the BBC Research and Development institute release their "Turing Codec" which is a HEVC encoder licensed under the GPL v2. Would it be possible to add integration to ffmpeg?

Github repo is found here:
https://github.com/bbc/turingcodec

Change History (6)

comment:1 Changed 8 days ago by fantesy

  • Summary changed from Add Turing Codec (HEVC encoder) to Integration of Turing Codec (HEVC encoder)

comment:2 Changed 8 days ago by Gyan

comment:3 in reply to: ↑ description Changed 8 days ago by cehoyos

Replying to fantesy:

At the moment the only software HEVC encoder ffmpeg uses is libx265, and i don't know if you want to keep it that way, but in 2016 the BBC Research and Development institute release their "Turing Codec" which is a HEVC encoder licensed under the GPL v2. Would it be possible to add integration to ffmpeg?

Why do you believe this would be a good idea?
(Your answer may be able to invalidate the reasons for not accepting the patch.)

comment:4 Changed 8 days ago by fantesy

ok, my apologies I didn't know that it had already been submitted and rejected. I wasn't suggesting it based on performance or capabilities, more of giving people a different option and it was the only other HEVC encoder I was aware of. However if you have your reasons for not including it, I can accept that and I will close this ticket.

And again i would like to apologies, I wasn't aware that they had been bugging you guys about integrating it, I don't keep as up to date on the mailing list as I would like.

comment:5 Changed 8 days ago by fantesy

  • Resolution set to wontfix
  • Status changed from new to closed

comment:6 Changed 8 days ago by jkqxz

H.265 encoders currently available in ffmpeg:

  • x265 (software via libx265)
  • Kvazaar (software via libkvazaar)
  • Intel (software and hardware encoders via libmfx, or hardware-only via VAAPI)
  • AMD (hardware via AMF or VAAPI)
  • Nvidia (hardware via NVENC)

I think Turing would probably be accepted if there were any particular argument to do so, but currently it just looks like a closed research project:

  • It's pretty much stated that the API isn't stable, hence the suggested patch avoiding any common options and using the string argument stuff to push any incompatibility onto users.
  • The open-source project looks like an unsupported wall-throw - e.g. <https://github.com/bbc/turingcodec/commit/09a838c9feeb43ac410391e300b8b53ff660c721>.
  • There was little attempt to show that it's actually good for anything - no visible users, no useful benchmarks.
Note: See TracTickets for help on using tickets.