Opened 5 months ago

Closed 5 months ago

#7194 closed defect (duplicate)

Can't play/convert certain mp4 file

Reported by: newkind Owned by:
Priority: important Component: avformat
Version: git-master Keywords: mov regression
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Summary of the bug:

For some reason mp4 files downloaded using Firefox Video Download Helper can't be played or converted using FFmpeg.

I tested the video file and it plays fine in: VLC, mpv, QuickTime?, Soda Player and Kodi 17.6 on Android 7.1

So the issue exists only on my FFmpeg 4.0 on Mac and FFmpeg that ships with latest build CoreElec? Linux JEOS

I can of course provide the file on mega.co.nz platform, but it's a little bit heavy - 980mb.

How to reproduce:

ffmpeg started on 2018-05-09 at 11:36:43
Report written to "ffmpeg-20180509-113643.log"
Command line:
ffmpeg -v 9 -loglevel 99 -report -i tsubasa_zly.mp4
ffmpeg version 4.0 Copyright (c) 2000-2018 the FFmpeg developers
  built with Apple LLVM version 9.0.0 (clang-900.0.39.2)
  configuration: --prefix=/usr/local/Cellar/ffmpeg/4.0 --enable-shared --enable-pthreads --enable-version3 --enable-hardcoded-tables --enable-avresample --cc=clang --host-cflags= --host-ldflags= --enable-gpl --enable-libass --enable-libbs2b --enable-libmp3lame --enable-librtmp --enable-libtheora --enable-libvorbis --enable-libx264 --enable-libx265 --enable-libxvid --enable-opencl --enable-videotoolbox --enable-openssl --disable-lzma --enable-nonfree
  libavutil      56. 14.100 / 56. 14.100
  libavcodec     58. 18.100 / 58. 18.100
  libavformat    58. 12.100 / 58. 12.100
  libavdevice    58.  3.100 / 58.  3.100
  libavfilter     7. 16.100 /  7. 16.100
  libavresample   4.  0.  0 /  4.  0.  0
  libswscale      5.  1.100 /  5.  1.100
  libswresample   3.  1.100 /  3.  1.100
  libpostproc    55.  1.100 / 55.  1.100
Splitting the commandline.
Reading option '-v' ... matched as option 'v' (set logging level) with argument '9'.
Reading option '-loglevel' ... matched as option 'loglevel' (set logging level) with argument '99'.
Reading option '-report' ... matched as option 'report' (generate a report) with argument '1'.
Reading option '-i' ... matched as input url with argument 'tsubasa_zly.mp4'.
Finished splitting the commandline.
Parsing a group of options: global .
Applying option v (set logging level) with argument 9.
Applying option loglevel (set logging level) with argument 99.
Applying option report (generate a report) with argument 1.
Successfully parsed a group of options.
Parsing a group of options: input url tsubasa_zly.mp4.
Successfully parsed a group of options.
Opening an input file: tsubasa_zly.mp4.
[NULL @ 0x7fedd5002400] Opening 'tsubasa_zly.mp4' for reading
[file @ 0x7fedd3e16880] Setting default whitelist 'file,crypto'
[mov,mp4,m4a,3gp,3g2,mj2 @ 0x7fedd5002400] Format mov,mp4,m4a,3gp,3g2,mj2 probed with size=2048 and score=100
[mov,mp4,m4a,3gp,3g2,mj2 @ 0x7fedd5002400] ISO: File Type Major Brand: isom
[mov,mp4,m4a,3gp,3g2,mj2 @ 0x7fedd5002400] Unknown dref type 0x206c7275 size 12
[mov,mp4,m4a,3gp,3g2,mj2 @ 0x7fedd5002400] Processing st: 0, edit list 0 - media time: 7200, duration: 131529600
[mov,mp4,m4a,3gp,3g2,mj2 @ 0x7fedd5002400] drop a frame at curr_cts: 0 @ 0
[mov,mp4,m4a,3gp,3g2,mj2 @ 0x7fedd5002400] Unknown dref type 0x206c7275 size 12
[mov,mp4,m4a,3gp,3g2,mj2 @ 0x7fedd5002400] STSC entry 62927 is invalid (first=1 count=1 id=1)
[mov,mp4,m4a,3gp,3g2,mj2 @ 0x7fedd5002400] error reading header
[AVIOContext @ 0x7fedd3e169c0] Statistics: 1164294 bytes read, 1 seeks
tsubasa_zly.mp4: Invalid data found when processing input

Attachments (1)

ffmpeg-20180509-113643.log (2.8 KB) - added by newkind 5 months ago.

Download all attachments as: .zip

Change History (4)

Changed 5 months ago by newkind

comment:1 Changed 5 months ago by cehoyos

  • Keywords mov added

Please either provide the input file or confirm that this is a duplicate of ticket #7165.

comment:2 Changed 5 months ago by newkind

Issue sounds very similar but I noticed that the file provided as sample in #7165 doesn't play nicely in other players like mpv or VLC. The sample file from #7165 is reported as a 3 minute video but if you try to jump in the timeline - it closes the video at all times - hence my assumption of something being wrong with it. That's why I prefer to provide my own sample file below which plays and works just fine.

Here is my sample file : https://mega.nz/#!slp00BrS!4cUFy4cJuMtVO62jDsvSu6E17GEGim4izEPV-DPGOTo

comment:3 Changed 5 months ago by cehoyos

  • Component changed from undetermined to avformat
  • Keywords regression added
  • Priority changed from normal to important
  • Resolution set to duplicate
  • Status changed from new to closed
  • Version changed from unspecified to git-master

Duplicate of ticket #7165.

Note: See TracTickets for help on using tickets.