Opened 5 weeks ago

Closed 5 weeks ago

#7145 closed defect (fixed)

Non-standard default orientation for lissajous in avectorscope

Reported by: privatezero Owned by:
Priority: normal Component: avfilter
Version: git-master Keywords:
Cc: dave@dericed.com Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Summary of the bug: In the current git-master version of the avectorscope filter the lissajous mode is shifted 45 degrees in the wrong direction compared to standard audio lissajous scopes.

With a mono source and the output set to lissajous_xy, the output conforms to what one would expect to see on an audio vectorscope (a diagonal line rising from left to right), however in the default lissajous mode, a mono signal registers as a horizontal line rather than a vertical line as is expected. This effectively means that in default settings the filter is always erroneously indicating that in-phase audio is perfectly out of phase.
How to reproduce:

ffplay -f lavfi "sine=400,avectorscope=m=lissajous"
ffmpeg version N-45798-gb3b3a3e
built on 2018-04-17

Change History (3)

comment:1 Changed 5 weeks ago by dericed

  • Cc dave@dericed.com added

comment:2 Changed 5 weeks ago by richardpl

Because mirror is by default set to y. Set it to 0.

comment:3 Changed 5 weeks ago by richardpl

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.