Opened 3 weeks ago

Closed 3 weeks ago

Last modified 3 weeks ago

#7118 closed defect (invalid)

Unknown encoder OSX 10.9 Mavericks

Reported by: Atalantia Owned by:
Priority: normal Component: undetermined
Version: unspecified Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Summary of the bug:
How to reproduce:
/usr/local/Cellar/ffmpeg/3.4.2/bin/ffmpeg -loglevel 24 -i ~/path/to/myMovie.avi -c:v libx265 -crf 28 -c:a aac -b:a 128k ~/path/to/newMovie.mp4

--> Unknown encoder 'libx265'

A search for libx265 I finds:

40.0 B Alias 01.04.18 12:26 01.04.18 12:26 /usr/local/lib/libx265.151.dylib libx265.151.dylib
32.0 B Alias 01.04.18 12:26 01.04.18 12:26 /usr/local/lib/libx265.a libx265.a
36.0 B Alias 01.04.18 12:26 01.04.18 12:26 /usr/local/lib/libx265.dylib libx265.dylib
17.0 B Alias 01.04.18 12:26 01.04.18 12:26 /usr/local/Cellar/x265/2.7/lib/libx265.dylib libx265.dylib
13.4 MB Ar Archive 01.04.18 12:26 01.04.18 12:26 /usr/local/Cellar/x265/2.7/lib/libx265.a libx265.a
11.1 MB Dynamic Library 01.04.18 12:26 01.04.18 12:26 /usr/local/Cellar/x265/2.7/lib/libx265.151.dylib libx265.151.dylib

Change History (5)

comment:1 Changed 3 weeks ago by cehoyos

  • Component changed from ffmpeg to undetermined
  • Keywords libx265 removed
  • Priority changed from important to normal
  • Version changed from 3.2.4 to unspecified

You need to enable optional codecs at compile time, please ask all usage and build questions on the FFmpeg user mailing list, this is a bug tracker.

comment:2 Changed 3 weeks ago by cehoyos

  • Resolution set to invalid
  • Status changed from new to closed

comment:3 Changed 3 weeks ago by Atalantia

  • Component changed from undetermined to ffmpeg
  • Keywords libx265 added
  • Priority changed from normal to important
  • Version changed from unspecified to 3.4

comment:4 Changed 3 weeks ago by cehoyos

  • Component changed from ffmpeg to undetermined
  • Keywords libx265 removed
  • Priority changed from important to normal
  • Version changed from 3.4 to unspecified

comment:5 Changed 3 weeks ago by testh001

Hello, @cehoyos

Unrelated to this issue, but I think you haven't seen my last comment on issue https://trac.ffmpeg.org/ticket/7115

Can you please review that comment, because I posted all relevant details there. Is it possible to reopen #7115?

Thanks.

Note: See TracTickets for help on using tickets.