Opened 10 months ago

Closed 5 days ago

#7041 closed defect (wontfix)

Transcoding Lame encoded mp3 fails with "Missing Header"

Reported by: hendrik Owned by:
Priority: normal Component: undetermined
Version: git-master Keywords: mp3
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Summary of the bug:

"Missing header" while transcoding mp3 to wav.
Related to https://trac.ffmpeg.org/ticket/5689 ?

When decoding the file with CoreAudio? on macOS 10.13.3, no error occurs.

How to reproduce:
I used the static snapshot built for Mac to reproduce: https://evermeet.cx/ffmpeg/ffmpeg-90148-g0419623cdc.7z

in.mp3 will be attached.

% ffmpeg -i in.mp3 out.wav
ffmpeg version N-90148-g0419623cdc-tessus Copyright (c) 2000-2018 the FFmpeg developers
  built with Apple LLVM version 9.0.0 (clang-900.0.39.2)
  configuration: --cc=/usr/bin/clang --prefix=/opt/ffmpeg --extra-version=tessus --enable-avisynth --enable-fontconfig --enable-gpl --enable-libass --enable-libbluray --enable-libfreetype --enable-libgsm --enable-libmodplug --enable-libmp3lame --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libopus --enable-libsnappy --enable-libsoxr --enable-libspeex --enable-libtheora --enable-libvidstab --enable-libvo-amrwbenc --enable-libvorbis --enable-libvpx --enable-libwavpack --enable-libx264 --enable-libx265 --enable-libxavs --enable-libxvid --enable-libzmq --enable-libzvbi --enable-version3 --pkg-config-flags=--static --disable-ffplay
  libavutil      56.  7.101 / 56.  7.101
  libavcodec     58. 12.102 / 58. 12.102
  libavformat    58.  9.100 / 58.  9.100
  libavdevice    58.  2.100 / 58.  2.100
  libavfilter     7. 12.100 /  7. 12.100
  libswscale      5.  0.101 /  5.  0.101
  libswresample   3.  0.101 /  3.  0.101
  libpostproc    55.  0.100 / 55.  0.100
Input #0, mp3, from 'in.mp3':
  Metadata:
    title           : Drop That Low (When I Dip) (Original Mix)
    artist          : Tujamo
    album           : Drop That Low (When I Dip) [Extended Mix] - Single
    genre           : Electro House
    TIT1            : DJ
    TBPM            : 126
    fBPM2           : 63.0067
    fBPM_Salience   : 0.98391604
    Meter           : 4/4
    TimeSignatureAlgorithm: OnsetPeak;v=4.6.3
    Beats           : SteadyBeats;1532517;476139;268747;1;
    BeatsAlgorithm  : OnsetPeak;v=4.6.3
    replaygain_track_gain: -11.1428 dB
    replaygain_track_peak: 1
    fBPM            : 126.0
    BPMAlgorithm    : OnsetPeak;v=4.6.3
    beaTunes_SPECTRUM: 32.350395;26.503937;15.980315;26.893702;30.401575;15.590551;33.519684;20.267717;43.65354;58.464565;99.0;48.720474;88.86614;97.05118;52.228348;61.972443;77.95276;59.244095;53.397636;49.5;58.074802;47.55118;25.72441;0.0;
    beaTunes_COLOR  : b8135d
    tags            :
    Similarities    : 39938:135233:83777;13931:90279:45325;14489:185945:44768;72260:228484:36408;167369:228484:36408;205635:228484:34922;2414:234800:29907;182230:220496:29535;10959:220496:29350;0:87121:29350;87121:220496:29350;190217:205635:27863;18947:205635:27678;34179:95108
    SimilaritiesAlgorithm: SimpleDiagonalPaths;v=4.6.3
    Segments        : 0:13931:C:UNKOWN;13931:45325:A:REFRAIN;59257:13188:D:UNKOWN;72260:18018:B-:VERSE;90279:45325:A:REFRAIN;135604:7987:C:UNKOWN;143592:9102:C:UNKOWN;152694:14860:E:UNKOWN;167369:18575:B-:VERSE;185945:44768:A:REFRAIN;230713:38266:B:OUTRO;
    SegmentsAlgorithm: SimpleDiagonalPaths;v=4.6.3
    iTunNORM        :  000032D2 000032D2 00007F0D 00007F0D 00000000 00000000 00008000 00008000 00000000 00000000
    TKEY            : 11d
    date            : 2016
    id3v2_priv.TRAKTOR4: DMRT\xbbV\x01\x00\x02\x00\x00\x00RDH 0\x00\x00\x00\x03\x00\x00\x00SKHC\x04\x00\x00\x00\x00\x00\x00\x007i\xbc\x00DOMF\x04\x00\x00\x00\x00\x00\x00\x00\x0a\x06\xe0\x07NSRV\x04\x00\x00\x00\x00\x00\x00\x00\x07\x00\x00\x00ATADsV\x01\x00\x14\x00\x00\x00BDNA\x04\
  Duration: 00:04:28.75, start: 0.025056, bitrate: 327 kb/s
    Stream #0:0: Audio: mp3, 44100 Hz, stereo, s16p, 320 kb/s
    Metadata:
      encoder         : LAME3.93
    Side data:
      replaygain: track gain - -11.142800, track peak - 0.000023, album gain - unknown, album peak - unknown,
    Stream #0:1: Video: mjpeg, yuvj420p(pc, bt470bg/unknown/unknown), 500x500 [SAR 72:72 DAR 1:1], 90k tbr, 90k tbn, 90k tbc
    Metadata:
      comment         : Cover (front)
Stream mapping:
  Stream #0:0 -> #0:0 (mp3 (native) -> pcm_s16le (native))
Press [q] to stop, [?] for help
Output #0, wav, to 'out.wav':
  Metadata:
    INAM            : Drop That Low (When I Dip) (Original Mix)
    IART            : Tujamo
    IPRD            : Drop That Low (When I Dip) [Extended Mix] - Single
    IGNR            : Electro House
    TIT1            : DJ
    TBPM            : 126
    fBPM2           : 63.0067
    fBPM_Salience   : 0.98391604
    Meter           : 4/4
    TimeSignatureAlgorithm: OnsetPeak;v=4.6.3
    Beats           : SteadyBeats;1532517;476139;268747;1;
    BeatsAlgorithm  : OnsetPeak;v=4.6.3
    replaygain_track_gain: -11.1428 dB
    replaygain_track_peak: 1
    fBPM            : 126.0
    BPMAlgorithm    : OnsetPeak;v=4.6.3
    beaTunes_SPECTRUM: 32.350395;26.503937;15.980315;26.893702;30.401575;15.590551;33.519684;20.267717;43.65354;58.464565;99.0;48.720474;88.86614;97.05118;52.228348;61.972443;77.95276;59.244095;53.397636;49.5;58.074802;47.55118;25.72441;0.0;
    beaTunes_COLOR  : b8135d
    tags            :
    Similarities    : 39938:135233:83777;13931:90279:45325;14489:185945:44768;72260:228484:36408;167369:228484:36408;205635:228484:34922;2414:234800:29907;182230:220496:29535;10959:220496:29350;0:87121:29350;87121:220496:29350;190217:205635:27863;18947:205635:27678;34179:95108
    SimilaritiesAlgorithm: SimpleDiagonalPaths;v=4.6.3
    Segments        : 0:13931:C:UNKOWN;13931:45325:A:REFRAIN;59257:13188:D:UNKOWN;72260:18018:B-:VERSE;90279:45325:A:REFRAIN;135604:7987:C:UNKOWN;143592:9102:C:UNKOWN;152694:14860:E:UNKOWN;167369:18575:B-:VERSE;185945:44768:A:REFRAIN;230713:38266:B:OUTRO;
    SegmentsAlgorithm: SimpleDiagonalPaths;v=4.6.3
    iTunNORM        :  000032D2 000032D2 00007F0D 00007F0D 00000000 00000000 00008000 00008000 00000000 00000000
    TKEY            : 11d
    ICRD            : 2016
    id3v2_priv.TRAKTOR4: DMRT\xbbV\x01\x00\x02\x00\x00\x00RDH 0\x00\x00\x00\x03\x00\x00\x00SKHC\x04\x00\x00\x00\x00\x00\x00\x007i\xbc\x00DOMF\x04\x00\x00\x00\x00\x00\x00\x00\x0a\x06\xe0\x07NSRV\x04\x00\x00\x00\x00\x00\x00\x00\x07\x00\x00\x00ATADsV\x01\x00\x14\x00\x00\x00BDNA\x04\
    ISFT            : Lavf58.9.100
    Stream #0:0: Audio: pcm_s16le ([1][0][0][0] / 0x0001), 44100 Hz, stereo, s16, 1411 kb/s
    Metadata:
      encoder         : Lavc58.12.102 pcm_s16le
    Side data:
      replaygain: track gain - -11.142800, track peak - 0.000023, album gain - unknown, album peak - unknown,
[mp3 @ 0x7fda4d811200] Header missingate=1406.5kbits/s speed= 230x
Error while decoding stream #0:0: Invalid data found when processing input
size=   46287kB time=00:04:28.69 bitrate=1411.2kbits/s speed= 272x
video:0kB audio:46286kB subtitle:0kB other streams:0kB global headers:0kB muxing overhead: 0.000506%}}}
Patches should be submitted to the ffmpeg-devel mailing list and not this bug tracker.

Change History (4)

comment:1 Changed 10 months ago by hendrik

You can find the sample file at http://www.tagtraum.com/download/in.mp3 (as I wasn't able to attach it due to size limitations)

comment:2 Changed 10 months ago by cehoyos

  • Keywords header missing removed

Why do you think there is a bug?

comment:3 Changed 10 months ago by hendrik

Because I can read through the file just fine using CoreAudio?.

comment:4 Changed 5 days ago by richardpl

  • Resolution set to wontfix
  • Status changed from new to closed

This is because file contains both id3 metadata at start and apetags at end, last one is invalid. Also apetags are invalid as they contain junk data at end.

Note: See TracTickets for help on using tickets.