Opened 4 weeks ago

Closed 2 weeks ago

#7029 closed defect (fixed)

libtls: unable to connect to numeric hosts

Reported by: chainik Owned by:
Priority: normal Component: avformat
Version: git-master Keywords: tls
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no


ffmpeg: tls: server name not specified

The error is caused by no server name being specified, yet verification is enabled. With a numeric host it passes NULL as the server name to tls_connect_cbs(), which will cause the "server name not specified" failure.

We should probably disable at least name verification for numeric hosts.

Change History (1)

comment:1 Changed 2 weeks ago by cehoyos

  • Keywords tls added
  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.