Opened 3 months ago

Closed 4 weeks ago

#6968 closed defect (fixed)

`silencedetect` only logs start of silence – not end and duration

Reported by: annoying Owned by:
Priority: normal Component: avfilter
Version: git-master Keywords: silencedetect
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

not sure if this is a bug or expected behavior. for an audio file that only contains silence, this command only logs the beginning of silence (– no end and duration):
[silencedetect @ 0x7ff3977000c0] silence_start: -0.00628118

command:
ffmpeg -i silence-31s.mp3 -af "silencedetect=n=-50dB:d=1" -f null -

ffmpeg version:
3.4.1

Attachments (1)

silence-31s.mp3 (485.3 KB) - added by annoying 3 months ago.

Download all attachments as: .zip

Change History (4)

Changed 3 months ago by annoying

comment:1 Changed 3 months ago by Gyan

End time and duration are updated by the filter when it gets to the next non-silent sample. For a fully silent file, that will never happen.

This could be considered a bug since a segment of silence has to end sometime even if at the end of file.

comment:2 Changed 3 months ago by cehoyos

  • Component changed from undetermined to avfilter
  • Keywords silencedetect added; silence removed
  • Version changed from unspecified to git-master

comment:3 Changed 4 weeks ago by richardpl

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.