Opened 6 months ago

Closed 6 months ago

#6935 closed enhancement (fixed)

Could not find Jpeg2000 codestream atom

Reported by: compn Owned by:
Priority: wish Component: avcodec
Version: git-master Keywords: j2k
Cc: Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: no

Description

libopenjpeg works:
ffmpeg -c libopenjpeg -i sn85032933-19081114.jp2 out.png

native jpeg2k fails.
not sure if lavf or lavc problem.

C:\Users\Downloads>ffmpeg -i sn85032933-19081114.jp2 out.png
ffmpeg version git-2017-12-25-613f789 Copyright (c) 2000-2017 the FFmpeg developers

built with gcc 7.2.0 (GCC)
configuration: --enable-gpl --enable-version3 --enable-sdl2 --enable-bzlib --enable-fontconfig --enable-gnutls --enable-ico

nv --enable-libass --enable-libbluray --enable-libfreetype --enable-libmp3lame --enable-libopencore-amrnb --enable-libopencor
e-amrwb --enable-libopenjpeg --enable-libopus --enable-libshine --enable-libsnappy --enable-libsoxr --enable-libtheora --enab
le-libtwolame --enable-libvpx --enable-libwavpack --enable-libwebp --enable-libx264 --enable-libx265 --enable-libxml2 --enabl
e-libzimg --enable-lzma --enable-zlib --enable-gmp --enable-libvidstab --enable-libvorbis --enable-libvo-amrwbenc --enable-li
bmysofa --enable-libspeex --enable-amf --enable-cuda --enable-cuvid --enable-d3d11va --enable-nvenc --enable-dxva2 --enable-a
visynth --enable-libmfx

libavutil 56. 7.100 / 56. 7.100
libavcodec 58. 9.100 / 58. 9.100
libavformat 58. 3.100 / 58. 3.100
libavdevice 58. 0.100 / 58. 0.100
libavfilter 7. 7.100 / 7. 7.100
libswscale 5. 0.101 / 5. 0.101
libswresample 3. 0.101 / 3. 0.101
libpostproc 55. 0.100 / 55. 0.100

[jpeg2000 @ 000000000052bc00] Could not find Jpeg2000 codestream atom.
[j2k_pipe @ 0000000000519080] decoding for stream 0 failed
[j2k_pipe @ 0000000000519080] Could not find codec parameters for stream 0 (Video: jpeg2000, none): unspecified size
Consider increasing the value for the 'analyzeduration' and 'probesize' options
Input #0, j2k_pipe, from 'sn85032933-19081114.jp2':

Duration: N/A, bitrate: N/A

Stream #0:0: Video: jpeg2000, none, 25 tbr, 25 tbn, 25 tbc

Stream mapping:

Stream #0:0 -> #0:0 (jpeg2000 (native) -> png (native))

Press [q] to stop, ? for help
[jpeg2000 @ 0000000000521600] Could not find Jpeg2000 codestream atom.
Error while decoding stream #0:0: Invalid data found when processing input
Finishing stream 0:0 without any data written to it.
Nothing was written into output file 0 (out.png), because at least one of its streams received no packets.
frame= 0 fps=0.0 q=0.0 Lsize=N/A time=-577014:32:22.77 bitrate=N/A speed=N/A
video:0kB audio:0kB subtitle:0kB other streams:0kB global headers:0kB muxing overhead: unknown
Output file is empty, nothing was encoded (check -ss / -t / -frames parameters if used)
Conversion failed!

Change History (3)

comment:2 Changed 6 months ago by cehoyos

  • Component changed from undetermined to avcodec
  • Keywords j2k added
  • Priority changed from normal to wish
  • Reproduced by developer set
  • Status changed from new to open

Patch sent.

comment:3 Changed 6 months ago by cehoyos

  • Resolution set to fixed
  • Status changed from open to closed
Note: See TracTickets for help on using tickets.