Opened 12 days ago

Closed 12 days ago

#6892 closed defect (fixed)

vf_hflip.asm using 64b operands in 32b compile

Reported by: LigH Owned by:
Priority: important Component: avfilter
Version: git-master Keywords: hflip
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Compiling ffmpeg with Win32 target. Reported compiling errors:

X86ASM  libavfilter/x86/vf_hflip.o
H:/dev/mabs/build/ffmpeg-git/libavfilter/x86/vf_hflip.asm:62: error: invalid operands in non-64-bit mode
H:/dev/mabs/build/ffmpeg-git/libavfilter/x86/vf_hflip.asm:64: error: invalid operands in non-64-bit mode
make: *** [/build/ffmpeg-git/ffbuild/common.mak:82: libavfilter/x86/vf_hflip.o] Error 1

According to the location reported above, the reason are the two "mov" commands in this block, which uses an unconditional ssse3 initialization:

    .loop1:
        neg    xq
        mov    vb, [srcq + xq]
        neg    xq
        mov    [dstq + xq], vb
        add    xq, 1
        cmp    xq, wq
        jl .loop1
    .end:

Attachments (1)

logs.zip (147.7 KB) - added by LigH 12 days ago.
Log files archive collected by media-autobuild_suite

Download all attachments as: .zip

Change History (3)

Changed 12 days ago by LigH

Log files archive collected by media-autobuild_suite

comment:1 Changed 12 days ago by cehoyos

  • Keywords hflip added; assembler x86_64 ssse3 removed
  • Priority changed from normal to important

comment:2 Changed 12 days ago by cehoyos

  • Resolution set to fixed
  • Status changed from new to closed

Fixed by Paul

Note: See TracTickets for help on using tickets.