Opened 5 years ago

Closed 5 years ago

Last modified 4 years ago

#6802 closed enhancement (duplicate)

Enable closed captions with NVENC

Reported by: Ruben Sanchez Castellano Owned by:
Priority: wish Component: avcodec
Version: git-master Keywords: cc nvenc
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

When using NVENC (h264_nvenc) as hardware encoder for H.264, if the input file has Closed Captions attached to the frame data as side data then the resulting video does not have thos closed captions.

I attached the patch for nvenc.c file from FFmpeg 3.4.

Attachments (2)

nvenc_ffmpeg_3_4_diif.rtf (3.8 KB ) - added by Ruben Sanchez Castellano 5 years ago.
Patch for NVENC that solves the issue
nvenc_ffmpeg_3_3_4_diff.rtf (3.5 KB ) - added by Ruben Sanchez Castellano 5 years ago.
Patch for NVENC that solves the issue for FFmpeg 3.3.4

Download all attachments as: .zip

Change History (5)

by Ruben Sanchez Castellano, 5 years ago

Attachment: nvenc_ffmpeg_3_4_diif.rtf added

Patch for NVENC that solves the issue

by Ruben Sanchez Castellano, 5 years ago

Attachment: nvenc_ffmpeg_3_3_4_diff.rtf added

Patch for NVENC that solves the issue for FFmpeg 3.3.4

comment:1 by Hendrik, 5 years ago

Patches should be made against Git master and submitted to the mailing list.

comment:2 by Carl Eugen Hoyos, 5 years ago

Keywords: cc nvenc added; nvidia h264 removed
Priority: importantwish
Resolution: duplicate
Status: newclosed
Type: defectenhancement

Duplicate of ticket #6726, a patch was apparently already suggested.

comment:3 by Dennis E. Mungai, 4 years ago

The issue with #6726 is that the apparently suggested patch was never applied.

Perhaps this ticket should remain open until the issue is solved?

Note: See TracTickets for help on using tickets.