Opened 5 weeks ago

Closed 4 weeks ago

#6772 closed defect (invalid)

zimg (zscale) supports choosing bitdepth, not supported in ffmpeg

Reported by: mtc Owned by:
Priority: minor Component: undetermined
Version: unspecified Keywords: zscale
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

https://ffmpeg.org/ffmpeg-all.html#zscale-1

https://github.com/sekrit-twc/zimg

depth module provides for conversion between … pixel … formats
… IEEE-754 binary16 (OpenEXR) and binary32 formats.
… including conversion between such formats.

but not ffmpeg command-line options that can use it

also mentions

conversion between YCbCr and RGB

thus add also support form in/out of RGB spaces (not just YUV-based?)

Change History (3)

comment:1 Changed 5 weeks ago by cehoyos

  • Keywords plugin z.lib removed

comment:2 Changed 5 weeks ago by heleppkes

Your ticket doesn't seem very clear what you are actually asking for?

vf_zscale supports conversion between pixel formats, which includes conversion from YCbCr to RGB, as well as changing bitdepth as required. There is no specific "bitdepth" option, because the bitdepth in ffmpeg is controlled/implied through the pixel format you ask to convert to.

comment:3 Changed 4 weeks ago by richardpl

  • Resolution set to invalid
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.