Opened 5 weeks ago

Closed 5 weeks ago

#6760 closed defect (duplicate)

Gray screen after transcoding media pix_fmt yuv444p10le to yuv420p. Macroblocks visible

Reported by: leogdiniz Owned by:
Priority: normal Component: undetermined
Version: unspecified Keywords:
Cc: leonardo.diniz@hotmart.com, br, bruno.santana@hotmart.com.br, paulo.ribeiro@hotmart.com.br Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Summary of the bug:
When transcoding a video that uses h264 codec and pixel format yuv444p10le to h264 yuv420p on any ffmpeg version after 3.0.8 the transcoded media is all messed up with a gray screen.
I found out the using ffmpeg 3.0.8 the problem won't happen. However it hapens on version 3.0.9 and after.
How to reproduce:

Download the file from this URL:
https://s3.amazonaws.com/player.hotmart.dev/test/ffmpeg_ticket/h264_pix_fmt_444.mkv
The file has 2.5MB
Open the terminal and move to the folder where you downloaded the file above.
Run the command:

docker run -t -v /$(pwd):/home leonardodinizhotmart/ffmpeg:3.4 ffmpeg -i /home/h264_pix_fmt_444.mkv -pix_fmt yuv420p /home/output.mp4

The output.mp4 file will have the problem.
https://s3.amazonaws.com/player.hotmart.dev/test/ffmpeg_ticket/thumbnail.jpg
If you run the command bellow the problem won't happen:

docker run -t -v /$(pwd):/home leonardodinizhotmart/ffmpeg:3.0.8 ffmpeg -i /home/h264_pix_fmt_444.mkv -pix_fmt yuv420p /home/output.mp4

The Docker file information can be found at https://hub.docker.com/r/leonardodinizhotmart/ffmpeg

The ffmpeg -v 9 -loglevel 99 log can be found at:
https://s3.amazonaws.com/player.hotmart.dev/test/ffmpeg_ticket/log-3.0.8.txt
https://s3.amazonaws.com/player.hotmart.dev/test/ffmpeg_ticket/log-3.4.txt

I see that ffmpeg reports a gray chroma error during the encoding on version 3.4. I can't see why it's doing this since that on version 3.0.8 it works just fine =(

Attachments (3)

h264_pix_fmt_444.mkv (2.3 MB) - added by leogdiniz 5 weeks ago.
The input file for the test
log-3.4.txt (6.5 KB) - added by leogdiniz 5 weeks ago.
Log of the file using ffmpeg versoin 3.4
log-3.0.8.txt (5.5 KB) - added by leogdiniz 5 weeks ago.
Log of the file using ffmpeg versoin 3.0.8

Change History (4)

Changed 5 weeks ago by leogdiniz

The input file for the test

Changed 5 weeks ago by leogdiniz

Log of the file using ffmpeg versoin 3.4

Changed 5 weeks ago by leogdiniz

Log of the file using ffmpeg versoin 3.0.8

comment:1 Changed 5 weeks ago by cehoyos

  • Component changed from ffmpeg to undetermined
  • Keywords transcode yuv420p gray chroma removed
  • Priority changed from important to normal
  • Resolution set to duplicate
  • Status changed from new to closed
  • Version changed from 3.1.7 to unspecified

Sound like a duplicate of #6717
If you know how to create such broken files, please explain!

Note: See TracTickets for help on using tickets.