Opened 4 weeks ago

Closed 2 weeks ago

Last modified 2 weeks ago

#6684 closed defect (fixed)

videotoolbox encoder doesn't build in latest git

Reported by: lagnat Owned by:
Priority: important Component: build system
Version: git-master Keywords: osx videotoolbox regression
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

configure doesn't set CONFIG_H264_VIDEOTOOLBOX_ENCODER. Git bisect'ed to this commit.

9ef5a2f5f30bdc4ac86275ae4b4708ab4681b21d is the first bad commit
commit 9ef5a2f5f30bdc4ac86275ae4b4708ab4681b21d
Author: Clément Bœsch <cboesch@gopro.com>
Date: Fri Jul 28 13:39:00 2017 +0200

build: simplify weak-enabling of autodetected libraries

:100755 100755 b5e3629db0cdba08cc97d60f9b2d1a4d855af895 fea9f956b8c41e204bed03d3047ec334504ae9b6 M configure

Attachments (2)

config.h (71.0 KB) - added by lagnat 4 weeks ago.
config.log (453.5 KB) - added by lagnat 4 weeks ago.

Download all attachments as: .zip

Change History (6)

comment:1 Changed 4 weeks ago by cehoyos

  • Keywords osx regression added
  • Priority changed from normal to important

comment:2 Changed 4 weeks ago by heleppkes

When you report build issues, please provide a config.log and config.h

Changed 4 weeks ago by lagnat

Changed 4 weeks ago by lagnat

comment:3 Changed 2 weeks ago by cehoyos

  • Resolution set to fixed
  • Status changed from new to closed

comment:4 Changed 2 weeks ago by cehoyos

  • Keywords videotoolbox added
Note: See TracTickets for help on using tickets.