Opened 7 weeks ago

Closed 7 weeks ago

#6622 closed defect (invalid)

Doesn't support wav files completely - incorrect time length reported

Reported by: nemo Owned by:
Priority: normal Component: avformat
Version: unspecified Keywords: wav
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

(FFmpeg <- LAVFilters <- MPC-HC)

It doesn't report the time length correctly on some wav files.

Example: https://mega.nz/#!YuomER6Y!YNkShluWwT47YI085AS170xTbV_seFFfpbtC_7tLMfU
Time length is 11:42 according to VLC.
MPC-HC reports itime length as 03:43 however when it reaches that time it continues to play.

The example was downloaded 2017-08-18 and is free this month.
More can be found here: http://www.mysurround.com/en/catalog-free-titles
(Creating an account is free).

MPC-HC (64-bit)
---------------

Build information:
    Version:            1.7.13 (e37826845)
    Compiler:           MSVC v19.00.24215.01
    Build date:         Jul 16 2017 18:47:17

LAV Filters:
    LAV Splitter:       0.70.2.1
    LAV Video:          0.70.2.1
    LAV Audio:          0.70.2.1
    FFmpeg compiler:    MinGW-w64 GCC 7.1.0

Operating system:
    Name:               Windows NT 6.1 (build 7601, Service Pack 1)
    Version:            6.1 (64-bit)

Reference: https://github.com/Nevcairiel/LAVFilters/issues/151

mkver said:
"This is ac3 muxed in a wave container (if you look at the file in an hex editor, you will find many 0x00 in it (this is also the reason why this file is so compressibly); also, there seems to be an endianness swap on the ac3 data, but I actually don't know the specification of ac3 in wav). The 11:42 reported by VLC is also wrong: The real length is 3:24.768. This seems to be a bug in ffmpeg (or a limitation of ac3 in wav) and should be reported there. LAVFilters will inherit the fix for it (if it gets fixed)."

Change History (5)

comment:1 Changed 7 weeks ago by oromit

Does ffprobe also report the wrong length? All the various other tools have not a lot of meaning for ffmpeg itself.

comment:2 Changed 7 weeks ago by cehoyos

  • Resolution set to invalid
  • Status changed from new to closed

Please reopen this ticket if you can provide the FFmpeg command line and the complete, uncut console output that show the issue you see and if the issue is reproducible with current FFmpeg git head.

comment:3 follow-up: Changed 7 weeks ago by nemo

  • Resolution invalid deleted
  • Status changed from closed to reopened

I'm unable to get it to work. No matter what I do all I get is "access denied" in the console.
Could you please do it instead?

comment:4 in reply to: ↑ 3 Changed 7 weeks ago by cehoyos

Replying to nemo:

I'm unable to get it to work. No matter what I do all I get is "access denied" in the console.

Could you please do it instead?

Do what?

comment:5 Changed 7 weeks ago by cehoyos

  • Component changed from undetermined to avformat
  • Keywords wav added
  • Resolution set to invalid
  • Status changed from reopened to closed

I don't think this is a valid ticket, a useful sample can be downloaded from http://www.mysurround.com/test/TestMySurround-en.dbr.wav.zip

Note: See TracTickets for help on using tickets.