Opened 3 months ago

Closed 2 weeks ago

#6558 closed defect (fixed)

libavformat discards chapters in mp3 files

Reported by: danimo Owned by:
Priority: important Component: avformat
Version: git-master Keywords: id3v2 regression
Cc: atze@fem.tu-ilmenau.de Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: no

Description

Summary of the bug:
How to reproduce:

% ffprobe -input http://chaosradio.ccc.de/archive/reproducer/1.mp3
ffmpeg version 3.3.0
(reproducable up until master)

Previous ffmpeg versions would display chapter marks (ffprobe) or be able to transfer/export them (ffmpeg). Since ffmpeg 3.3.0, this is no longer possible.

I have run a git bisect with the reproducer line above, and ended up finding that 65862f57ad2f7f49d715f334a9d892e0b20d42f1 is the culprit.

"avformat: Ignore ID3v2 tags if other tags are present e.g. vorbis"

It switches from ff_id3v2_read to ff_id3v2_read_dict. Following the description of the functions, this would be the reason why the chapter marks went missing:

ff_id3v2_read_dict: Read an ID3v2 tag into specified dictionary and retrieve supported extra metadata.
ff_id3v2_read: Read an ID3v2 tag, including supported extra metadata and chapters.

However, I am sure how to proceed from here. Either the chapters really discarded, or do they end up in id3v2_extra_meta, being improperly handled there.

Change History (4)

comment:1 Changed 3 months ago by atze

  • Cc atze@fem.tu-ilmenau.de added

comment:2 Changed 3 months ago by danimo

Sorry, this was supposed to read "However, I am NOT sure how to proceed from here", obviously.

comment:3 Changed 2 weeks ago by cehoyos

  • Keywords id3v2 regression added
  • Priority changed from normal to important
  • Version changed from unspecified to git-master

comment:4 Changed 2 weeks ago by cehoyos

  • Reproduced by developer set
  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.