Opened 3 months ago

Closed 3 months ago

#6545 closed enhancement (fixed)

Hls Encryption reloaded at each segment

Reported by: JohnPi Owned by: stevenliu
Priority: normal Component: avformat
Version: git-master Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Hi,

I use Ffmpeg as HLS transcoder and i store my encryption key on a web server.
Today i find out ffmpeg reload the "file.keyinfo" and the key for each segment. This make the transcoding with HLS encryption impossible because the key request add latences.
It is possible to make FFmpeg load the keyinfo file and the key just one time at the begining of the encoding ?

Thank you by advance :)

Change History (3)

comment:1 Changed 3 months ago by stevenliu

  • Owner set to stevenliu
  • Status changed from new to open

comment:2 Changed 3 months ago by stevenliu

comment:3 Changed 3 months ago by stevenliu

  • Resolution set to fixed
  • Status changed from open to closed
Note: See TracTickets for help on using tickets.