Opened 5 months ago

Closed 5 months ago

#6504 closed defect (invalid)

Decklink device handling broken after 2017-05-30?

Reported by: BlackScreen Owned by:
Priority: normal Component: undetermined
Version: git-master Keywords: decklink
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Summary of the bug:
I use FFmpeg to capture video and audio from a Decklink card.
I am building FFmpeg myself with the media-autobuild_suite (https://github.com/jb-alvarado/media-autobuild_suite).
I keep old versions for myself for backup purposes. So long I did not have any issues using those builds for capturing from a Decklink card.
But since recently I saw that the handling of the Decklink card seems to be broken. I could narrow it down (from my backups) to a timespan between 2017-05-30 and 2017-06-16 where something changed that broke it. The old version (2017-05-30) does work, the newer ones, including the latest, do not work.
I have attached the log files for the builds I had at hand to test.

How to reproduce:

% ffmpeg -v 9 -loglevel 99 -f decklink -list_devices 1 -i dummy -report
ffmpeg version N-86494-g18f09524f7 (and newer)
built on 2017-06-16

Attachments (1)

ffmpeg_logs.zip (4.4 KB) - added by BlackScreen 5 months ago.
all logs to document the issue

Download all attachments as: .zip

Change History (3)

Changed 5 months ago by BlackScreen

all logs to document the issue

comment:1 Changed 5 months ago by cus

Most probably the build suite is using newer dirvers than what you have on your system.

https://github.com/jb-alvarado/media-autobuild_suite/commit/a7db96428d04d1618f5a7acad115777ef1e3b5cf

Do you have 10.9.3 or newer?

Please resolve this as invalid if that is indeed the problem.

comment:2 Changed 5 months ago by BlackScreen

  • Resolution set to invalid
  • Status changed from new to closed

You are right. That did the trick. Weird that all updates since then did work, but the newer commit broke it. I had 10.6.4 installed.
Thanks for your help!

Note: See TracTickets for help on using tickets.