Opened 6 months ago

Closed 6 months ago

Last modified 6 months ago

#6401 closed defect (invalid)

Unmet compilation dependency: libsdl2-dev, perhaps libwayland-dev

Reported by: wnorfl Owned by:
Priority: normal Component: undetermined
Version: unspecified Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

I'm following the "FFmpeg CompilationGuide/Ubuntu". Ubuntu 14.04. The first step, "Get the Dependencies" generates an error in installing libsdl2-dev:

$ sudo apt-get install libsdl2-dev
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libsdl2-dev : Depends: libegl1-mesa-dev
               Depends: libgles2-mesa-dev
               Depends: libwayland-dev but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

$ sudo apt-get install libwayland-dev
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libwayland-dev : Depends: libwayland-client0 (= 1.4.0-1ubuntu1) but 1.7.0-0ubuntu1~trusty1 is to be installed
                  Depends: libwayland-server0 (= 1.4.0-1ubuntu1) but 1.7.0-0ubuntu1~trusty1 is to be installed
                  Depends: libwayland-cursor0 (= 1.4.0-1ubuntu1) but 1.7.0-0ubuntu1~trusty1 is to be installed
E: Unable to correct problems, you have held broken packages.
$ 

I do realize that this may have nothing directly to do with FFmpeg. Nevertheless, suggestions?

Thank you for considering my question.

Change History (2)

comment:1 Changed 6 months ago by wnorfl

  • Resolution set to fixed
  • Status changed from new to closed

I see, just a version problem. libwayland's client, server, and cursor packages have gotten out ahead of libwayland itself (version 1.7.0 vs. 1.4.0). Hope I have not wasted your time.

comment:2 Changed 6 months ago by llogan

  • Component changed from ffmpeg to undetermined
  • Keywords libsdl2-dev dependency removed
  • Resolution changed from fixed to invalid
Note: See TracTickets for help on using tickets.