Opened 3 months ago

Closed 3 months ago

#6385 closed defect (duplicate)

Broken output for likely broken avi input

Reported by: dimabeliy Owned by:
Priority: important Component: undetermined
Version: git-master Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: no

Description

Summary of the bug:

I am trying to transcode from this avi to that mp4.
ffmpeg set for converted video incorrect duration time 296:53:54.84, but source video has 00:09:56.48 see output below.

How to reproduce:

% ffmpeg -i big_buck_bunny_480p_surround.AVI -c:v libx264 -preset slow -crf 22 -c:a aac -vf scale="trunc(in_w/2)*2:trunc(in_h/2)*2" -profile:v main -level 3.1 -pix_fmt yuv420p -movflags +faststart out.mp4
ffmpeg version 3.2.4-1~bpo8+1 Copyright (c) 2000-2017 the FFmpeg developers
  built with gcc 4.9.2 (Debian 4.9.2-10)
  configuration: --prefix=/usr --extra-version='1~bpo8+1' --toolchain=hardened --libdir=/usr/lib/x86_64-linux-gnu --incdir=/usr/include/x86_64-linux-gnu --enable-gpl --disable-stripping --enable-avresample --enable-avisynth --enable-gnutls --enable-ladspa --enable-libass --enable-libbluray --enable-libbs2b --enable-libcaca --enable-libcdio --disable-libebur128 --enable-libflite --enable-libfontconfig --enable-libfreetype --enable-libfribidi --enable-libgme --enable-libgsm --enable-libmodplug --enable-libmp3lame --enable-libopenjpeg --enable-libopus --enable-libpulse --enable-librubberband --enable-libshine --enable-libsnappy --enable-libsoxr --enable-libspeex --enable-libssh --enable-libtheora --enable-libtwolame --enable-libvorbis --enable-libvpx --enable-libwavpack --enable-libwebp --enable-libx265 --enable-libxvid --enable-libzmq --enable-libzvbi --enable-omx --enable-openal --enable-opengl --enable-sdl2 --enable-libdc1394 --enable-libiec61883 --enable-chromaprint --enable-frei0r --enable-libopencv --enable-libx264 --enable-shared
  libavutil      55. 34.101 / 55. 34.101
  libavcodec     57. 64.101 / 57. 64.101
  libavformat    57. 56.101 / 57. 56.101
  libavdevice    57.  1.100 / 57.  1.100
  libavfilter     6. 65.100 /  6. 65.100
  libavresample   3.  1.  0 /  3.  1.  0
  libswscale      4.  2.100 /  4.  2.100
  libswresample   2.  3.100 /  2.  3.100
  libpostproc    54.  1.100 / 54.  1.100
[avi @ 0x7f6bdf177020] non-interleaved AVI
Input #0, avi, from 'mmo_36168605_1493981420_5678_21789.avi':
  Metadata:
    encoder         : MEncoder 2:1.0~rc2-0ubuntu13
  Duration: 00:09:56.48, start: 0.000000, bitrate: 2958 kb/s
    Stream #0:0: Video: mpeg4 (Simple Profile) (FMP4 / 0x34504D46), yuv420p, 854x480 [SAR 1:1 DAR 427:240], 2500 kb/s, 24 fps, 24 tbr, 24 tbn, 24 tbc
    Stream #0:1: Audio: ac3 ([0] [0][0] / 0x2000), 48000 Hz, 5.1(side), fltp, 448 kb/s
[libx264 @ 0x7f6bdf17d8e0] using SAR=1/1
[libx264 @ 0x7f6bdf17d8e0] using cpu capabilities: MMX2 SSE2Fast SSSE3 SSE4.2 AVX
[libx264 @ 0x7f6bdf17d8e0] profile Main, level 3.1
[libx264 @ 0x7f6bdf17d8e0] 264 - core 142 r2431 a5831aa - H.264/MPEG-4 AVC codec - Copyleft 2003-2014 - http://www.videolan.org/x264.html - options: cabac=1 ref=5 deblock=1:0:0 analyse=0x1:0x111 me=umh subme=8 psy=1 psy_rd=1.00:0.00 mixed_ref=1 me_range=16 chroma_me=1 trellis=1 8x8dct=0 cqm=0 deadzone=21,11 fast_pskip=1 chroma_qp_offset=-2 threads=12 lookahead_threads=2 sliced_threads=0 nr=0 decimate=1 interlaced=0 bluray_compat=0 constrained_intra=0 bframes=3 b_pyramid=2 b_adapt=2 b_bias=0 direct=3 weightb=1 open_gop=0 weightp=2 keyint=250 keyint_min=24 scenecut=40 intra_refresh=0 rc_lookahead=50 rc=crf mbtree=1 crf=22.0 qcomp=0.60 qpmin=0 qpmax=69 qpstep=4 ip_ratio=1.40 aq=1:1.00
Output #0, mp4, to 'out.mp4':
  Metadata:
    encoder         : Lavf57.56.101
    Stream #0:0: Video: h264 (libx264) ([33][0][0][0] / 0x0021), yuv420p, 854x480 [SAR 1:1 DAR 427:240], q=-1--1, 24 fps, 12288 tbn, 24 tbc
    Metadata:
      encoder         : Lavc57.64.101 libx264
    Side data:
      cpb: bitrate max/min/avg: 0/0/0 buffer size: 0 vbv_delay: -1
    Stream #0:1: Audio: aac (LC) ([64][0][0][0] / 0x0040), 48000 Hz, 5.1(side), fltp, 341 kb/s
    Metadata:
      encoder         : Lavc57.64.101 aac
Stream mapping:
  Stream #0:0 -> #0:0 (mpeg4 (native) -> h264 (libx264))
  Stream #0:1 -> #0:1 (ac3 (native) -> aac (native))
Press [q] to stop, [?] for help
[mp4 @ 0x7f6bdf17f260] Starting second pass: moving the moov atom to the beginning of the file+03x    
frame=14315 fps= 39 q=-1.0 Lsize=   85287kB time=296:53:54.84 bitrate=   0.7kbits/s speed=2.94e+03x    
video:60047kB audio:24856kB subtitle:0kB other streams:0kB global headers:0kB muxing overhead: 0.452406%
[libx264 @ 0x7f6bdf17d8e0] frame I:144   Avg QP:15.92  size: 59301
[libx264 @ 0x7f6bdf17d8e0] frame P:8589  Avg QP:20.24  size:  5161
[libx264 @ 0x7f6bdf17d8e0] frame B:5582  Avg QP:24.59  size:  1545
[libx264 @ 0x7f6bdf17d8e0] consecutive B-frames: 43.1%  8.1% 19.8% 29.0%
[libx264 @ 0x7f6bdf17d8e0] mb I  I16..4: 29.8%  0.0% 70.2%
[libx264 @ 0x7f6bdf17d8e0] mb P  I16..4:  1.9%  0.0%  1.6%  P16..4: 30.4%  9.9%  7.2%  0.0%  0.0%    skip:49.1%
[libx264 @ 0x7f6bdf17d8e0] mb B  I16..4:  0.6%  0.0%  0.7%  B16..8: 23.3%  2.5%  0.6%  direct: 1.4%  skip:70.8%  L0:45.0% L1:48.1% BI: 6.9%
[libx264 @ 0x7f6bdf17d8e0] direct mvs  spatial:99.9% temporal:0.1%
[libx264 @ 0x7f6bdf17d8e0] coded y,uvDC,uvAC intra: 56.3% 68.2% 39.6% inter: 10.0% 15.1% 2.4%
[libx264 @ 0x7f6bdf17d8e0] i16 v,h,dc,p: 37% 26% 15% 21%
[libx264 @ 0x7f6bdf17d8e0] i4 v,h,dc,ddl,ddr,vr,hd,vl,hu: 14% 12% 10%  7% 11% 11% 11% 11% 13%
[libx264 @ 0x7f6bdf17d8e0] i8c dc,h,v,p: 43% 26% 18% 13%
[libx264 @ 0x7f6bdf17d8e0] Weighted P-Frames: Y:2.0% UV:1.1%
[libx264 @ 0x7f6bdf17d8e0] ref P L0: 67.7% 14.3% 10.7%  3.7%  2.3%  1.2%  0.0%
[libx264 @ 0x7f6bdf17d8e0] ref B L0: 80.6%  9.9%  8.2%  1.2%
[libx264 @ 0x7f6bdf17d8e0] ref B L1: 93.8%  6.2%
[libx264 @ 0x7f6bdf17d8e0] kb/s:824.70
[aac @ 0x7f6bdf1ac000] Qavg: 463.954

Attachments (1)

ffmpeg-20170511-115059.log.tar.bz2 (201.1 KB) - added by dimabeliy 3 months ago.

Download all attachments as: .zip

Change History (3)

Changed 3 months ago by dimabeliy

comment:2 Changed 3 months ago by cehoyos

  • Priority changed from normal to important
  • Reproduced by developer set
  • Resolution set to duplicate
  • Status changed from new to closed
  • Summary changed from Incorrect duration time in out converted file to Broken output for likely broken avi input
  • Version changed from 3.2.4 to git-master

For future tickets: Please remember to always test current FFmpeg git head.

Output file is broken since 967facb6 / ad95307f, duplicate of ticket #5144.

Note: See TracTickets for help on using tickets.