Opened 5 months ago

Closed 5 months ago

#6361 closed defect (duplicate)

Seeking fails for H264 file

Reported by: Krakean Owned by:
Priority: normal Component: undetermined
Version: git-master Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Summary of the bug:
Sample: ​​https://yadi.sk/i/jteUfal9hY7QR (press the "Скачать" to download)
Decoding is fine, but seek is broken.
PotPlayer? & Microsoft DTV-DVD Video decoder seeking normal.
How to reproduce:

% ffplay.exe no_recovery_ffmpeg.m2ts
ffplay version N-63843-g6d40849 Copyright (c) 2003-2014 the FFmpeg developers
  built on Jun  8 2014 22:02:04 with gcc 4.8.2 (GCC)
  configuration: --enable-gpl --enable-version3 --disable-w32threads --enable-avisynth --enable-bzlib --enable-fontconfig --enable-frei0r --enable-gnutls --enable-iconv --enable-li
bass --enable-libbluray --enable-libcaca --enable-libfreetype --enable-libgme --enable-libgsm --enable-libilbc --enable-libmodplug --enable-libmp3lame --enable-libopencore-amrnb --
enable-libopencore-amrwb --enable-libopenjpeg --enable-libopus --enable-librtmp --enable-libschroedinger --enable-libsoxr --enable-libspeex --enable-libtheora --enable-libtwolame -
-enable-libvidstab --enable-libvo-aacenc --enable-libvo-amrwbenc --enable-libvorbis --enable-libvpx --enable-libwavpack --enable-libwebp --enable-libx264 --enable-libx265 --enable-
libxavs --enable-libxvid --enable-decklink --enable-zlib
  libavutil      52. 89.100 / 52. 89.100
  libavcodec     55. 66.100 / 55. 66.100
  libavformat    55. 42.101 / 55. 42.101
  libavdevice    55. 13.101 / 55. 13.101
  libavfilter     4.  6.100 /  4.  6.100
  libswscale      2.  6.100 /  2.  6.100
  libswresample   0. 19.100 /  0. 19.100
  libpostproc    52.  3.100 / 52.  3.100
Input #0, mpegts, from 'no_recovery_ffmpeg.m2ts': sq=    0B f=0/0
  Duration: 00:01:58.20, start: 4328.545078, bitrate: 13543 kb/s
  Program 1
    Stream #0:0[0x1011]: Video: h264 (High) (HDMV / 0x564D4448), yuv420p(tv, bt709), 1920x1080 [SAR 1:1 DAR 16:9], 23.98 fps, 23.98 tbr, 90k tbn, 47.95 tbc
[h264 @ 0464ce20] mmco: unref short failure  49KB sq=    0B f=0/0
    Last message repeated 1 times
[h264 @ 0464c600] mmco: unref short failure   0KB sq=    0B f=0/0
[h264 @ 0464c600] number of reference frames (0+4) exceeds max (3; probably corrupt input), discarding one
[h264 @ 0464dc60] reference picture missing during reorder
[h264 @ 0464dc60] Missing reference picture, default is 65512
[h264 @ 045677c0] mmco: unref short failure
[h264 @ 045677c0] number of reference frames (0+4) exceeds max (3; probably corrupt input), discarding one
[h264 @ 0464dc60] reference picture missing during reorder
[h264 @ 0464dc60] Missing reference picture, default is 65512
[h264 @ 0464dc60] reference picture missing during reorderB f=0/0
[h264 @ 0464dc60] Missing reference picture, default is 65512
[h264 @ 0464dc60] reference picture missing during reorder
[h264 @ 0464dc60] Missing reference picture, default is 65512
[h264 @ 0464ce20] mmco: unref short failure 433KB sq=    0B f=0/0
[h264 @ 0464ce20] number of reference frames (0+4) exceeds max (3; probably corrupt input), discarding one
[h264 @ 04566700] mmco: unref short failure
[h264 @ 04566700] number of reference frames (0+4) exceeds max (3; probably corrupt input), discarding one
[h264 @ 05540a80] Missing reference picture, default is 00B f=0/0
[h264 @ 0464c600] reference picture missing during reorder
    Last message repeated 1 times
[h264 @ 0464c600] Missing reference picture, default is 0
    Last message repeated 1 times
[h264 @ 05540a80] Missing reference picture, default is 0
[h264 @ 0464dc60] mmco: unref short failure
[h264 @ 0464c600] reference picture missing during reorder
    Last message repeated 1 times
[h264 @ 0464c600] Missing reference picture, default is 0
    Last message repeated 1 times
[h264 @ 04566d00] reference picture missing during reorder
[h264 @ 04566d00] Missing reference picture, default is 65540
[h264 @ 05540a80] Missing reference picture, default is 0
[h264 @ 0464c600] reference picture missing during reorderB f=0/0
    Last message repeated 1 times
[h264 @ 0464c600] Missing reference picture, default is 0
    Last message repeated 1 times
[h264 @ 04566d00] reference picture missing during reorder
[h264 @ 04566d00] Missing reference picture, default is 65540
[h264 @ 05540a80] Missing reference picture, default is 00B f=0/0
[h264 @ 0464c600] reference picture missing during reorder
    Last message repeated 1 times
[h264 @ 0464c600] Missing reference picture, default is 0
    Last message repeated 1 times
[h264 @ 04566d00] reference picture missing during reorder
[h264 @ 04566d00] Missing reference picture, default is 65540
[h264 @ 04566d00] reference picture missing during reorder
[h264 @ 04566d00] Missing reference picture, default is 65540
[h264 @ 0464c600] mmco: unref short failure   0KB sq=    0B f=0/0
[h264 @ 0464c600] number of reference frames (0+4) exceeds max (3; probably corrupt input), discarding one
[h264 @ 0464dc60] mmco: unref short failure
[h264 @ 0464dc60] number of reference frames (0+4) exceeds max (3; probably corrupt input), discarding one
[h264 @ 0464c600] mmco: unref short failure 424KB sq=    0B f=0/0
[h264 @ 0464ce20] mmco: unref short failure  29KB sq=    0B f=0/0
[h264 @ 045677c0] reference picture missing during reorder
[h264 @ 045677c0] Missing reference picture, default is 65542
[h264 @ 04567fe0] mmco: unref short failure
[h264 @ 045677c0] reference picture missing during reorder
[h264 @ 045677c0] Missing reference picture, default is 65542
[h264 @ 045677c0] reference picture missing during reorder
[h264 @ 045677c0] Missing reference picture, default is 65542
[h264 @ 045677c0] reference picture missing during reorderB f=0/0
[h264 @ 045677c0] Missing reference picture, default is 65542

Change History (1)

comment:1 Changed 5 months ago by cehoyos

  • Component changed from avcodec to undetermined
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of ticket #3705.
Note that this is also reproducible with ffmpeg.

Note: See TracTickets for help on using tickets.