Opened 23 months ago

Closed 13 days ago

#6320 closed defect (fixed)

service_name of DVB-T channel showing strange character

Reported by: xamarin Owned by:
Priority: minor Component: avformat
Version: git-master Keywords: mpegts regression
Cc: Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: yes

Description

Get sample file from here:

https://trac.ffmpeg.org/ticket/6312

When you perform "ffmpeg -i mux_546000000_8000000_20170320202431.ts" it displays for the service_name a weird character at the beginning of the name:

'?BeMad? tv HD' instead of 'BeMad? tv HD'

Version ffmpeg-20170411-f1d80bc-win64-static. See attached screenshot.

Attachments (3)

weird_channel_name_character.png (33.0 KB) - added by xamarin 23 months ago.
iso_text_coding_small.ts (710.5 KB) - added by cus 2 weeks ago.
Sample with 0x10 0x00 0x02 (ISO-8859-2) text encoding
vlc-record-2013-02-25-08h34m55s-台視-_cut.ts (2.4 MB) - added by cehoyos 13 days ago.
Sample from vlc ticket 8235

Change History (7)

Changed 23 months ago by xamarin

comment:1 Changed 23 months ago by xamarin

Trac is doing weird stuff with the highlighting.

Last edited 23 months ago by xamarin (previous) (diff)

comment:2 Changed 23 months ago by cehoyos

  • Component changed from undetermined to avformat
  • Keywords mpegts regression added
  • Priority changed from normal to minor
  • Reproduced by developer set
  • Status changed from new to open
  • Version changed from unspecified to git-master

comment:3 Changed 22 months ago by cehoyos

  • Analyzed by developer set

Not really a regression since 0a51362b3f3c3a0df09b24fbd9049711bff6fb94
The issue is the missing character table conversion in getstr8. Reference is Annex A of http://www.etsi.org/deliver/etsi_en/300400_300499/300468/01.13.01_40/en_300468v011301o.pdf

Changed 2 weeks ago by cus

Sample with 0x10 0x00 0x02 (ISO-8859-2) text encoding

comment:4 Changed 13 days ago by cehoyos

  • Resolution set to fixed
  • Status changed from open to closed

Fixed in 5c515b5f7d64fb1fccc3e99cd50f01bfbdd2a794 with a lot of help from Marton.

Changed 13 days ago by cehoyos

Sample from vlc ticket 8235

Note: See TracTickets for help on using tickets.