Opened 8 months ago

Closed 8 months ago

Last modified 8 months ago

#6221 closed defect (invalid)

Oprimize streaming delay

Reported by: ankit.gupta Owned by:
Priority: normal Component: undetermined
Version: unspecified Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Good day I am using below ffmpeg command to convert live RTSP video feed to .m3u8 but this command have delay of 30 seconds, any help on how to minimize this delay

ffmpeg -rtsp_transport tcp -i rtsp://root:kastle@192.168.17.153/axis-media/media.amp -r 25 -crf 25 -preset faster -maxrate 500k -bufsize 1500k -c:v libx264 -hls_time 4 -hls_list_size 1 -hls_wrap 2 -start_number 1 -rtsp_transport tcp -y Z:/playlist.m3u8

Change History (2)

comment:1 Changed 8 months ago by oromit

  • Resolution set to invalid
  • Status changed from new to closed

Players need to load 3 segments before being able to play HLS playlists.
So a quite long delay is to be expected with HLS.
Use shorter segments, but it will never be low-latency. 10-15 seconds is probably the best you can get.

Also, this is not a bug, please use the ffmpeg-user mailing list for questions in the future.

comment:2 Changed 8 months ago by cehoyos

  • Priority changed from critical to normal
Note: See TracTickets for help on using tickets.