Opened 3 months ago

Closed 3 months ago

#6211 closed defect (invalid)

How do I work around...?

Reported by: Taose Owned by:
Priority: normal Component: undetermined
Version: unspecified Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Four years... you guys decided to cause me problems by removing url.h from avformat and now I can't figure out how the hell to work around it.

I'm working on getting the Vega Strike project back up and running and have come up against a compilation error based on an invalid use of an incomplete type (struct URLContext).

The usual fix for something like this would be to include url.h in the headers...but url.h is completely missing and no longer being installed with the standard repository.

Could someone please point me to any relevant documentation that would assist me with finding out how to update the code to be compliant with current FFmpeg standards for this particular item and working around not having url.h available?

https://github.com/Taose/Vegastrike-taose/issues/11

I'm currently on ffmpeg version 3.0.7-0ubuntu0.16.10.1 which is the standard repository stuff. I am fully prepared to investigate this but I'm at a bit of a dead end due to my unfamiliarity with ffmpeg.

Change History (1)

comment:1 Changed 3 months ago by cehoyos

  • Component changed from avformat to undetermined
  • Priority changed from wish to normal
  • Resolution set to invalid
  • Status changed from new to closed
  • Version changed from 3.0.4 to unspecified

Please post all questions on the api user mailing list, it is important for us that this is not a support forum but a bug tracker.
Please understand that both here and on the mailing lists, only current FFmpeg git head is supported.

Note: See TracTickets for help on using tickets.