Opened 5 months ago

Closed 4 months ago

#6208 closed defect (fixed)

flac misdetection

Reported by: tyngdekraften Owned by:
Priority: important Component: avformat
Version: git-master Keywords: flac cavs regression
Cc: Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: no

Description

Summary of the bug:
flac gets probed as cavs

How to reproduce:

% ffmpeg -i qyijql.flac
ffmpeg version N-83692-gb8a7dcbde2
libavutil      55. 47.100 / 55. 47.100
libavcodec     57. 81.100 / 57. 81.100
libavformat    57. 66.102 / 57. 66.102
libavdevice    57.  3.100 / 57.  3.100
libavfilter     6. 74.100 /  6. 74.100
libavresample   3.  2.  0 /  3.  2.  0
libswscale      4.  3.101 /  4.  3.101
libswresample   2.  4.100 /  2.  4.100
libpostproc    54.  2.100 / 54.  2.100
[file @ 0xb64a00] Setting default whitelist 'file,crypto'
[cavsvideo @ 0xb641a0] Format cavsvideo probed with size=2048 and score=51
[cavsvideo @ 0xb641a0] Before avformat_find_stream_info() pos: 0 bytes read:1024 seeks:0 nb_streams:1
[cavs @ 0xb65820] stc 0x00 is too large
[cavs @ 0xb65820] stc 0x00 is too large
[cavs @ 0xb65820] stc 0x00 is too large
[cavs @ 0xb65820] stc 0x00 is too large
[cavs @ 0xb65820] stc 0x00 is too large
[cavs @ 0xb65820] stc 0x00 is too large
[cavs @ 0xb65820] stc 0x00 is too large
[cavs @ 0xb65820] stc 0x00 is too large
[cavs @ 0xb65820] stc 0x00 is too large
[cavs @ 0xb65820] stc 0x00 is too large
[cavs @ 0xb65820] stc 0x00 is too large
[cavs @ 0xb65820] Dimensions invalid
[cavs @ 0xb65820] no frame decoded
[cavsvideo @ 0xb641a0] decoding for stream 0 failed
[cavsvideo @ 0xb641a0] Could not find codec parameters for stream 0 (Video: cavs, yuv420p): unspecified size
Consider increasing the value for the 'analyzeduration' and 'probesize' options
[cavsvideo @ 0xb641a0] After avformat_find_stream_info() pos: 1024 bytes read:1024 seeks:0 frames:1
Input #0, cavsvideo, from '/tmp/qyijql.flac':
  Duration: N/A, bitrate: N/A
    Stream #0:0, 1, 1/1200000: Video: cavs, yuv420p, 25 tbr, 1200k tbn, 25 tbc
Successfully opened the file.
At least one output file must be specified
[AVIOContext @ 0xb6cd60] Statistics: 1024 bytes read, 0 seeks

Attachments (1)

qyijql.flac (1.0 KB) - added by tyngdekraften 5 months ago.
misdetected flac

Download all attachments as: .zip

Change History (3)

Changed 5 months ago by tyngdekraften

misdetected flac

comment:1 Changed 5 months ago by cehoyos

  • Keywords flac cavs added
  • Status changed from new to open

comment:2 Changed 4 months ago by cehoyos

  • Keywords regression added
  • Priority changed from normal to important
  • Resolution set to fixed
  • Status changed from open to closed

Regression since 9f2fc126, fixed in 3733039610d76231e404ebf089f0ff2b9d8e5490

Note: See TracTickets for help on using tickets.