Opened 10 months ago

Closed 9 months ago

Last modified 9 months ago

#6205 closed defect (invalid)

Distortions in audio output when selecting input audio track 5 or higher

Reported by: ackjewt Owned by:
Priority: normal Component: avdevice
Version: git-master Keywords: decklink
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Summary of the bug:
While using input track 5 or higher, i hear distortions in the output. I've attached two files, one using audio tracks 3-4 (sdi_576i_audio_ch_3-4.avi) and one using audio tracks 5-6 (sdi_576i_audio_ch_5-6.avi)

Input:
720x576i25, 8 audio tracks

Using:
CentOS 7
FFmpeg-git
Latest Decklink SDK (10.8.5)

How to reproduce:

ffmpeg -report -v 9 -loglevel 99 -re -channels 8 -f decklink -i "DeckLink SDI@3" -pixel_format uyvy422 -af "pan=stereo|c0=c4|c1=c5" -vn -acodec pcm_s16le sdi_576i_audio_ch_5-6.avi
ffmpeg version N-83691-g7f62368 Copyright (c) 2000-2017 the FFmpeg developers
  built with gcc 4.8.5 (GCC) 20150623 (Red Hat 4.8.5-11)
  configuration: --prefix=/root/ffmpeg-static/target --pkg-config-flags=--static --extra-cflags=-I/root/ffmpeg-static/target/include --extra-ldflags=-L/root/ffmpeg-static/target/lib --bindir=/root/ffmpeg-static/bin --enable-decklink --extra-cflags=-I/usr/include/decklink-10.8.5 --extra-ldflags=-ldl --extra-libs=-ldl --enable-ffplay --enable-ffserver --enable-gpl --enable-libass --enable-libfdk-aac --enable-libfreetype --enable-libmp3lame --enable-libopus --enable-libtheora --enable-libvorbis --enable-libvpx --enable-libx264 --enable-libx265 --enable-nonfree
  libavutil      55. 47.100 / 55. 47.100
  libavcodec     57. 81.100 / 57. 81.100
  libavformat    57. 66.102 / 57. 66.102
  libavdevice    57.  3.100 / 57.  3.100
  libavfilter     6. 74.100 /  6. 74.100
  libswscale      4.  3.101 /  4.  3.101
  libswresample   2.  4.100 /  2.  4.100
  libpostproc    54.  2.100 / 54.  2.100

Attachments (1)

out.wav (2.4 MB) - added by ackjewt 10 months ago.

Change History (7)

comment:2 Changed 10 months ago by cehoyos

  • Component changed from undetermined to ffmpeg
  • Keywords decklink added; Decklink SDI Audio removed

Did you upload the logs to an external location to make it less likely that a developer looks at the issue?

Please provide an output file for the following command:

$ ffmpeg -channels 8 -f decklink -i "DeckLink SDI@3" -acodec copy out.wav

Changed 10 months ago by ackjewt

comment:3 Changed 10 months ago by ackjewt

No, i thought that putting everything in the same place made more sense. Sorry for that.

I've attached the wav to the ticket. Let me know if you need a longer sample file.

comment:4 Changed 10 months ago by cehoyos

  • Component changed from ffmpeg to avdevice

I wanted to suggest -af "channelmap=4|5:stereo" to fix your issue but the distortions are already in the decklink stream, not produced by the filter chain.
Do you have another possibility to record eight-channel audio from this device?

comment:5 Changed 9 months ago by ackjewt

  • Resolution set to fixed
  • Status changed from new to closed

Thank you for the suggestion. I was looking for something like that instead of the pan filter.

I've found the issue now. It was related to how the Decklink card is handling of "audio sample distribution" when using SD (576i in this case). The issue is not there when using HD. The issue is also solved on newer Decklink cards.

comment:6 Changed 9 months ago by cehoyos

  • Resolution changed from fixed to invalid

Thank you for the additional information!

Note: See TracTickets for help on using tickets.