Opened 5 weeks ago

Closed 5 weeks ago

Last modified 5 weeks ago

#6161 closed defect (invalid)

Wrong WAV duration only in json format

Reported by: lkentaro Owned by:
Priority: normal Component: ffprobe
Version: git-master Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

ffprobe returns wrong wav duration, only in json format

ffprobe.exe -v quiet -print_format json -show_format -i 2.wav
{

"format": {

"filename": "2.wav",
"nb_streams": 1,
"nb_programs": 0,
"format_name": "wav",
"format_long_name": "WAV / WAVE (Waveform Audio)",
"duration": "333.658549",
"size": "58857412",
"bit_rate": "1411201",
"probe_score": 99

}

}

---
without json format

ffprobe.exe -i 2.wav
Input #0, wav, from '2.wav':

Duration: 00:05:33.66, bitrate: 1411 kb/s

Stream #0:0: Audio: pcm_s16le ([1][0][0][0] / 0x0001), 44100 Hz, 2 channels,

s16, 1411 kb/s

---
wav file
https://drive.google.com/open?id=0B9_F3Jst6nCIaEFmNkhkbEMwZWM

I don't know why, but another wav file works fine, show the correct duration.

Change History (3)

comment:1 Changed 5 weeks ago by Cigaes

What makes you think the duration is incorrect?

comment:2 Changed 5 weeks ago by heleppkes

It actually lists the same duration in both cases, since 333.66 seconds is equal to 00:05:33.66, its just a different format.

Last edited 5 weeks ago by heleppkes (previous) (diff)

comment:3 Changed 5 weeks ago by lkentaro

  • Resolution set to invalid
  • Status changed from new to closed

I made confusion at the time of the conversion, sorry.

I think
333.65/60 = 5,56.... = 05m:56s

Last edited 5 weeks ago by lkentaro (previous) (diff)
Note: See TracTickets for help on using tickets.