Opened 2 months ago

Closed 2 months ago

#6137 closed defect (duplicate)

J2C image sequence to RGB QuickTime results in "End mismatch 1" error

Reported by: owenaar Owned by:
Priority: normal Component: undetermined
Version: unspecified Keywords: j2k
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Summary of the bug:
I am trying to create an RGB QuickTime? from an XYZ .j2c image sequence. The command works as expected, but throws a LOT of End mismatch 1 errors during the process.

How to reproduce:
ffmpeg -r 24 -i input_000000.j2c -c:v libx264 -preset ultrafast -crf 22 -an -pix_fmt yuv420p -s 666x360 -r 24 output.mov

Console Output:
CINE-4:~ cinematiq$ ffmpeg -v 9 -loglevel 99 -i
ffmpeg version 3.2.3 Copyright (c) 2000-2017 the FFmpeg developers

built with Apple LLVM version 8.0.0 (clang-800.0.42.1)
configuration: --prefix=/usr/local/Cellar/ffmpeg/3.2.3 --enable-shared --enable-pthreads --enable-gpl --enable-version3 --enable-hardcoded-tables --enable-avresample --cc=clang --host-cflags= --host-ldflags= --enable-libmp3lame --enable-libx264 --enable-libxvid --enable-opencl --disable-lzma --enable-vda
libavutil 55. 34.101 / 55. 34.101
libavcodec 57. 64.101 / 57. 64.101
libavformat 57. 56.101 / 57. 56.101
libavdevice 57. 1.100 / 57. 1.100
libavfilter 6. 65.100 / 6. 65.100
libavresample 3. 1. 0 / 3. 1. 0
libswscale 4. 2.100 / 4. 2.100
libswresample 2. 3.100 / 2. 3.100
libpostproc 54. 1.100 / 54. 1.100

Splitting the commandline.
Reading option '-v' ... matched as option 'v' (set logging level) with argument '9'.
Reading option '-loglevel' ... matched as option 'loglevel' (set logging level) with argument '99'.
Reading option '-i' ...Missing argument for option 'i'.
Error splitting the argument list: Invalid argument
CINE-4:~ cinematiq$

Attachments (1)

input_000000.j2c (196.8 KB) - added by owenaar 2 months ago.
DCI compliant .j2c image in XYZ colorspace

Download all attachments as: .zip

Change History (3)

Changed 2 months ago by owenaar

DCI compliant .j2c image in XYZ colorspace

comment:1 Changed 2 months ago by owenaar

Updated command for image sequence:
ffmpeg -r 24 -i input_%6d.j2c -c:v libx264 -preset ultrafast -crf 22 -an -pix_fmt yuv420p -s 666x360 -r 24 output.mov

comment:2 Changed 2 months ago by cehoyos

  • Keywords j2k added; j2c removed
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of ticket #4827

Note: See TracTickets for help on using tickets.