Opened 5 months ago

Closed 5 months ago

Last modified 5 months ago

#6133 closed defect (wontfix)

TimeStamp Correction Incompetence

Reported by: ilkertezcan Owned by:
Priority: normal Component: ffmpeg
Version: git-master Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

While FFmpeg can reduce the file size to only certain amount of downloaded real data by triming gap bytes in the played audio / video files, The output (remux) file's the timestamp remains same with the original file.

The info-graphics that I designed to representatived the issue:
http://i.imgur.com/B0EML6v.png
http://i.imgur.com/zwjOmWs.png

ffmpeg -i ElephantsDream_only_a_few_scenes.mkv -c:a copy -c:v copy Remuxed.mkv

The sample file: https://mega.nz/#!xkpEGbSL!MJZVjnwhuQ4XD7EcmM3ahKLeINwUMSCEQD0fAqtU_gs

FFmpeg's report: https://paste.ee/r/5Zwci

ElephantsDream_only_a_few_scenes.mkv's file-size: 193 MB
ElephantsDream_only_a_few_scenes.mkv's timestamp:

00:10:58.13

Remuxed.mkv's file-size: 23 MB
Remuxed.mkv's timestamp:

00:10:58.13

*

FFmpeg is deprived of timestamp correction but MEncoder isn't. How can MEncoder can manage things while FFMpeg cannot?

MEncoder ElephantsDream_only_a_few_scenes.mkv -ni -ovc copy -oac copy -fafmttag 0x706D -of lavf -lavfopts format=mkv -o Corrected_by_MEncoder.mkv 

MEncoder's report: https://paste.ee/r/LzO4M

Corrected_by_MEncoder.mkv's new timestamp:

00:01:46

*

Also, The Meteorite Project (A MKV Repair Engine) software able to correct timestamp. (But Meteorite has its own issue which it has stuck at final stage -99%-. Order to overcome this, it will be necessary to re-mux the sample file with FFmpeg-3.1.5. In later versions of FFmpeg-3.1.5, the Meteorite directly crash without fix to the file).

The sources codes of Meteorite CLI version (I think, Meteoirite.cpp & MeteoireCLI.cpp files is enough):
https://github.com/cbielow/meteorite

FFmpeg -i ElephantsDream_only_a_few_scenes.mkv -c:a copy -c:v copy ElephantsDream_only_a_few_scenes-ffmpeg-3-1-5-remuxed.mkv

Meteoritecli ElephantsDream_only_a_few_scenes-ffmpeg-3-1-5-remuxed.mkv

Meteorite's report: https://paste.ee/r/VJWCS

Meteorite.ElephantsDream_only_a_few_scenes-ffmpeg-3-1-5-remuxed.mkv's timestamp
(Download for final fixed file):

00:01:41

Change History (2)

comment:1 Changed 5 months ago by cehoyos

  • Resolution set to wontfix
  • Status changed from new to closed

To the best of my knowledge, the input file is invalid and cannot be used to show a missing feature.

comment:2 Changed 5 months ago by ilkertezcan

Finally!

Like MEncoder and Meteorite, I hoped FFmpeg can also correct the timestamp and I was spending my days and nights for this matter, I also would spend my days because of this. With my all sincerity, I'm much more grateful to see "Won't fix" rather than to see "fixed". I'm so relieved after knowing that FFmpeg now being acknowledge as it is: incapable. Because you saved me from wasting my time in vain. God bless you...

I present my regards to you and Michael Niedermayer.

I admire all your programming skills. All you serve to millions by using your valuable time. The utmost video sites such as Youtube, Vimeo etc. would be having troubles without all you, indeed. I hope all developers can get what they deserve, both materially and morally.

Note: See TracTickets for help on using tickets.