Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#6040 closed defect (worksforme)

Build fails due to incorrect path for dirac_dwt.c

Reported by: dgorst Owned by:
Priority: normal Component: undetermined
Version: git-master Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Summary of the bug:

Build is attempting to find dirac_dwt.c in libavcodec/x86

How to reproduce:

%  ./configure --enable-gpl --enable-nonfree --enable-libx264 --enable-libvidstab

make

ffmpeg version : latest Git (47cd8effea343e71c4010929ed3fb10dd3dca4b1)

built on ...

Linux dgorst-All-Series 4.4.0-57-lowlatency #78-Ubuntu SMP PREEMPT Sat Dec 10 01:37:35 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux

Ubuntu 16.04.1 LTS

Output :

make: *** No rule to make target 'libavcodec/x86/dirac_dwt.c', needed by 'libavcodec/x86/dirac_dwt.o'.  Stop.

Change History (4)

comment:1 Changed 3 years ago by dgorst

Looks like the file is present - it's just getting the wrong directory :

dgorst@dgorst-All-Series:~/ffmpeg$ find . -name 'dirac_dwt.c'
./libavcodec/dirac_dwt.c
dgorst@dgorst-All-Series:~/ffmpeg$ find . -name 'dirac_dwt.asm'
./libavcodec/x86/dirac_dwt.asm

comment:2 Changed 3 years ago by dgorst

--disable-asm works as a workaround for now.

comment:3 Changed 3 years ago by cehoyos

  • Component changed from avcodec to undetermined
  • Resolution set to worksforme
  • Status changed from new to closed

Always run make distclean before reporting build issues.

comment:4 Changed 3 years ago by dgorst

I have. Also a fresh checkout. It worked the second time after a distclean for some reason.

2002 make distclean
2003 ./configure --enable-gpl --enable-nonfree --enable-libx264 --enable-libvidstab
2004 make -j 9
2005 history
2006 make distclean
2007 make -j 9
2008 ./configure --enable-gpl --enable-nonfree --enable-libx264 --enable-libvidstab
2009 make -j 9

Note: See TracTickets for help on using tickets.