Opened 3 years ago

Closed 3 years ago

#6003 closed defect (fixed)

Cannot build ffmpeg due to compile error

Reported by: jkherr Owned by:
Priority: important Component: undetermined
Version: git-master Keywords: vaapi
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

I'm compiling ffmpeg on a linux machine, and it's built for the
past several years. I just updated git-master after being gone
for several months, and I get this.

CC libavcodec/vaapi_vp9.o
libavcodec/vaapi_vp9.c: In function 'fill_picture_parameters':
libavcodec/vaapi_vp9.c:41:7: error: 'VADecPictureParameterBufferVP9 {aka struct _VADecPictureParameterBufferVP9}' has no member named 'bit_depth'

pp->bit_depth = h->h.bpp;

Am I missing some new library?

John.

Change History (3)

comment:1 Changed 3 years ago by cehoyos

  • Keywords vaapi added

comment:2 Changed 3 years ago by jkqxz

This was caused by incomplete VP9 support in libva before 1.7.0 (versions 1.6.0 to 1.6.2 will hit this issue).

Fixed by db7271bff2a6ad1890c9fd95e8126082bbeab9c7.

comment:3 Changed 3 years ago by jkqxz

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.