Opened 2 years ago

Closed 2 years ago

#5963 closed defect (needs_more_info)

Improve "unknown side data type" warning

Reported by: michael.heuberger Owned by:
Priority: minor Component: undetermined
Version: unspecified Keywords:
Cc: michael.heuberger@binarykitchen.com Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Summary of the bug:
How to reproduce:

% ffmpeg -f image2 -thread_queue_size 2048 -framerate 16.2 -i /home/michael-heuberger/binarykitchen/code/videomail.io/var/local/tmp/clients/videomail.io/11e6-ae01-6faeb620-97fa-87ea7a14b57c/frames/%d.webp -y -an -vcodec libvpx -filter:v drawtext=fontfile=/home/michael-heuberger/binarykitchen/code/videomail.io/src/assets/fonts/Varela-Regular.ttf:text=www.videomail.io:fontsize=10:fontcolor=0xFFFFFF@0.25:x=text_h:y=main_h-(text_h*2):shadowcolor=0x111111@0.15:shadowx=1:shadowy=1,scale=trunc(iw/2)*2:trunc(ih/2)*2 -crf 12 -deadline realtime -cpu-used 4 -pix_fmt yuv420p -loglevel warning /home/michael-heuberger/binarykitchen/code/videomail.io/var/local/tmp/clients/videomail.io/11e6-ae01-6faeb620-97fa-87ea7a14b57c/videomail_preview.webm
ffmpeg version 3.0.2-1ubuntu3 Copyright (c) 2000-2016 the FFmpeg developers
  built with gcc 6.1.1 (Ubuntu 6.1.1-11ubuntu12) 20160805
  configuration: --prefix=/usr --extra-version=1ubuntu3 --toolchain=hardened --libdir=/usr/lib/x86_64-linux-gnu --incdir=/usr/include/x86_64-linux-gnu --cc=cc --cxx=g++ --enable-gpl --enable-shared --disable-stripping --disable-decoder=libopenjpeg --disable-decoder=libschroedinger --enable-avresample --enable-avisynth --enable-gnutls --enable-ladspa --enable-libass --enable-libbluray --enable-libbs2b --enable-libcaca --enable-libcdio --enable-libflite --enable-libfontconfig --enable-libfreetype --enable-libfribidi --enable-libgme --enable-libgsm --enable-libmodplug --enable-libmp3lame --enable-libopenjpeg --enable-libopus --enable-libpulse --enable-librubberband --enable-librtmp --enable-libschroedinger --enable-libshine --enable-libsnappy --enable-libsoxr --enable-libspeex --enable-libssh --enable-libtheora --enable-libtwolame --enable-libvorbis --enable-libvpx --enable-libwavpack --enable-libwebp --enable-libx265 --enable-libxvid --enable-libzvbi --enable-openal --enable-opengl --enable-x11grab --enable-libdc1394 --enable-libiec61883 --enable-libzmq --enable-frei0r --enable-chromaprint --enable-libx264
  libavutil      55. 17.103 / 55. 17.103
  libavcodec     57. 24.102 / 57. 24.102
  libavformat    57. 25.100 / 57. 25.100
  libavdevice    57.  0.101 / 57.  0.101
  libavfilter     6. 31.100 /  6. 31.100
  libavresample   3.  0.  0 /  3.  0.  0
  libswscale      4.  0.100 /  4.  0.100
  libswresample   2.  0.101 /  2.  0.101
  libpostproc    54.  0.100 / 54.  0.100
Hyper fast Audio and Video encoder

Running the above command always prints this warning "unknown side data type 10 (24 bytes)"

No idea what it means and no idea how to correct/fix this. Can you improve this warning so that it tells us more what's wrong?

Thanks :)

Change History (4)

comment:1 Changed 2 years ago by michael.heuberger

  • Cc michael.heuberger@binarykitchen.com added
  • Keywords usability warning added

comment:2 Changed 2 years ago by jamrial

Update to a newer ffmpeg build and try again with it. I'm fairly sure any version newer than 3.0.x will show the actual type of side data ffmpeg is reporting about in this specific case.

In any case there's nothing wrong and it's nothing you need to fix/correct. The CLI simply prints any internal side data available, even if it doesn't recognize it. It's merely informative and not a warning or an error.

comment:3 Changed 2 years ago by michael.heuberger

I hear you, thanks. But it's irritating because this string is printed via stderr, not via stdout, hence interpreted as a warning/error.

Btw, I have installed ffmpeg via apt-get on Ubuntu 16.10 - there is no newer build avail.

But still, since I care about the videos I encode for the heavily used https://www.videomail.io site, I really want to understand what "unknown side data type" means and where it comes from.

comment:4 Changed 2 years ago by cehoyos

  • Keywords usability warning removed
  • Resolution set to needs_more_info
  • Status changed from new to closed
  • Type changed from enhancement to defect

Please reopen this ticket if the issue is reproducible with current FFmpeg git head.

Note: See TracTickets for help on using tickets.